Not logged inRybka Chess Community Forum
Up Topic Rybka Support & Discussion / Aquarium / Aquarium under Linux (FAQ)
1 2 3 Previous Next  
- - By Felix Kling (Gold) Date 2008-08-07 22:11 Edited 2016-06-27 09:58
(In this FAQ "Linux" means Ubuntu, but it will be similar for other distributions)
Warning: The latest Aquarium (2016) has problems with reading and creating trees if running with Wine.

1.Aquarium doesn't start - what can I do?

Use Winetricks to get vcrun2008, search for the file MSVCR90.dll in your Wine folder and copy it to your .wine/drive_c/windows/system32/ folder. That's it :)

2. I do have a problem that the top buttons are not visible in Wine (the titlebar used by Gnome hides it). Is there any solution?

Deactivate the gnome decorations in the Winecfg program (graphics-> allow window manager to decorate windows).

3. When analysing, a line break between the depths is missing, I only see one single line. What can I do?

Get Winetricks and install "riched30".
If you use a compiled 64 bit version, try this script: . In order to use it, replace "$WINE " (note the space at the end!) in the script with "/home/<Username>/<PathToWine>/wine ".

If installing riched30 doesn't help, a workaround is using the "Wrap lines" option (right click in the engine output window)

4. In Aquarium the board coordinates are chess symbols. On chessplanet the clock times are chesssymbols, too. Why?

You need to (re)install the ttf-mscorefonts-installer package. Under Ubuntu e.g. open a terminal and type: sudo apt-get install  ttf-mscorefonts-installer (for reinstallation: sudo apt-get install --reinstall ttf-mscorefonts-installer). That solves the problem.

5. After installing Aquarium, I get some gdi plus errors by Wine. What can I do?

This is sometimes a pretty rare bug. In my case uninstalling these worked for some reason:
ttf-bengali-fonts (1:0.5.4ubuntu2)
ttf-kannada-fonts (1:0.5.4ubuntu2)
ttf-oriya-fonts (1:0.5.4ubuntu2)
ttf-telugu-fonts (1:0.5.4ubuntu2)
ttf-wqy-zenhei (0.6.26-2ubuntu1)

6. Can I use the 64-bit Rybka versions in Aquarium under Linux?

Yes, installing 64 bit engines is no problem.

7. Can I use the 64-bit Aquarium under Linux?

Unfortunately no, but this is no big problem. You can still use 64 bit engines.

8. There are error messages during installation, what can I do?

In a terminal, type winetricks vcrun2010 gdiplus riched30 riched20

Also make sure you install the 32-bit Auqarium (64 bit doesn't run).

9. What can I do if all this didn't help?

Write a message in this forum. If there's no useful response, send me a private message, I sometimes miss posts.
Attachment: Screenshot.png (308k)
Parent - - By Patrick79 (**) Date 2008-08-08 08:26
Thanks, looks well.

I do have a problem that the top buttons are not visible in Wine (the titlebar used by Gnome hides it).
Parent - - By Felix Kling (Gold) Date 2008-08-08 08:47 Edited 2008-08-08 14:50
Ok, deactivate the gnome decorations in the Winecgf program (graphics-> allow window manager to decorate windows). That solves the problem :)
Parent - By Patrick79 (**) Date 2008-08-09 08:04
Thanks, that fixed the problem.
Parent - - By pgeorges (*) Date 2008-08-14 07:52 Edited 2008-08-14 07:58

When clicking on handicap game (skill option), I have an error "Microsoft MSXML is not installed".
I manually installed MSXML6.msi file, but the error is still there.
I am running Aquarium under Linux with wine, but this should not be the problem here.

So what version of MSXML is needed ?

Pascal Georges
Parent - - By Zruty (*****) Date 2008-08-14 11:17
Workaround: don't use skill handicap below 2000 (I think) for now.
I think we didn't include some DLL that is present in Windows but isn't by default in Wine.
Parent - By pgeorges (*) Date 2008-08-14 12:00
That's right : with play skill at 2100, it works but equal or below 2000 does not.
Could you please post name(s) of missing DLLs, so I can fix things by myself ?

Pascal Georges
Parent - - By Felix Kling (Gold) Date 2008-08-14 11:19
Did you try winedoors? with that program you can install everything automatically and it's easier to install things like the media player. Maybe installing it with winedoors is better.
Parent - - By pgeorges (*) Date 2008-08-14 12:04
I did not try winedoors, but I don't understand how it could fetch or report missing DLLs that will only pop up an error at runtime ?
I installed msxml6.msi with standard wine but Aquarium still report a missing MSXML DLL.

Pascal Georges
Parent - - By Felix Kling (Gold) Date 2008-08-14 12:10
with windeoors you can install msxml 3 and 4 and such things. I think this could really help!
Parent - - By pgeorges (*) Date 2008-08-14 12:39 Edited 2008-08-14 13:02
I installed msxml 3, 4 and 6 with commands like
wine msiexec /i msxml.msi

and I still got the msxml missing error.

But now I solved it :-) :
I ran strace on Aquarium and noticed at line 442882 (!)

open("/usr/bin/../lib/wine/", O_RDONLY|O_LARGEFILE) = 110
close(110)                              = 0
write(2, "err:module:load_builtin_dll fail"..., 141err:module:load_builtin_dll failed to load .so lib for builtin L"msxml3.dll": /usr/bin/../lib/wine/ undefined symbol: xsltInit
) = 141

And the symbol xsltInit is not present despite the fact that libxslt is installed. So a fix is to run wincfg and on libraries tab configure msxml3 as a native library.

Pascal Georges
Parent - - By Felix Kling (Gold) Date 2008-08-14 12:44
I don't know details, but often there are some special parameters needed, that's why I recommended winedoors, since it does that for you.
Anyway, my Wine has no problems with it, but I may have some dlls you don't have.
Parent - By pgeorges (*) Date 2008-08-14 13:05
In my case it was in fact broken Linux libraries, simply fixed by running wincfg and configuring msxml3 as a native library.

Thank you for the help.

Pascal Georges
Parent - - By brunjes (**) Date 2008-08-23 19:11
When I put Rybka 3 into analysis mode under Aquarium, the analysis window that shows each iteration of the search does NOT include a carriage return and so the analysis lines all run together in a very wide (too wide to display) line. Under Windows, this does not seem to happen. Has anyone found a fix for this?

Here is an example of the PVs not getting a CR in between them:

[-0.44  d=14] 2...exf4 3. Nf3 g5 4.Bc4 Nc6 5.h3 a6 6.Nc3 h6 7.O-O b5 (0:00.52) [-0.44 d=13] 2...exf4 3.Nf3 etc.

Note that the d=13 PV should be on a new line (and a scroll bar provided to see d=12, d=11, etc. As it stands now, all those lines are one huge line that cannot be displayed fully.

Tips for a solution are greatly appreciated,

Parent - - By Felix Kling (Gold) Date 2008-08-23 20:46
I had this problem some time ago, do you use the latest versions of Wine and Aquarium?
Parent - - By brunjes (**) Date 2008-08-23 23:32
I am using the latest of both and the problem persists.

Parent - - By Felix Kling (Gold) Date 2008-08-24 06:00
OK, maybe you can try to get exactly the Wine setup I have on my machine:
1) Set Windows version in winecfg to XP
2) Get all the Microsoft things you can download with WineDoors (you can get it from , maybe it's also in Synaptic)

Tell me if that helped.
Parent - By brunjes (**) Date 2008-08-24 14:38
I installed WineDoors and there is no difference. The Windows version was already set to XP for me.

Parent - - By brunjes (**) Date 2008-08-24 14:45
Have you tried the Chessbase GUI (new one) with Rybka 3? Does that work better under Wine? I would happily pay $ for that if it worked.


Parent - - By Felix Kling (Gold) Date 2008-08-24 18:27
The chessbase version doens't work well with Wine. If you click on the menu the program is frozen. Aquarium is the way to go for Linux users...
You need to install all the Microsoft Windows things in Winedoors, not just the program... all the fonts and so on.
Parent - - By brunjes (**) Date 2008-08-24 20:15
I had not installed the fonts and such. I did now and the result is the same. I certainly do not need to install things like Firefox 2, WinAMP, Windows Media Player, right? I did install Mono, all fonts, VB dlls. Is it necessary to install Foundation classes for C++? I would not believe so but then again, I'm not the developer of Rybka so I wouldn't know.


Parent - - By Felix Kling (Gold) Date 2008-08-24 21:45
I don't know. I just installed those things, use the latest Wine and the problem doesn't occure anymore... my idea for you was just to get the same settings I have. Maybe this is one of the richedit things or gdi plus, but I don't know.
Parent - By Zruty (*****) Date 2008-08-25 08:55
Aquarium uses both RichEdit and GDI+, so you might be right.
Parent - - By buffos (Silver) Date 2008-08-24 15:41
Smthg about the fonts you used to tell? Maybe that?
Parent - - By brunjes (**) Date 2008-08-27 23:11
I am using the default fonts supplied with Aquarium, so that should not be the issue -- correct me if I'm wrong about that.

Parent - By buffos (Silver) Date 2008-08-27 23:12
I thought that Felix had some problems with the fonts on linux, or smthg like that. I am not a Linux guy so i am not sure i can help.
Parent - - By Felix Kling (Gold) Date 2008-08-27 23:26 Edited 2008-08-27 23:28
You could use my fonts: . They are based on FreeSans and look better than the standard ones I think. Maybe you could try it, but of course I dont know if it really helps... just copy them in your windows/fonts directory and create a backup of prgchef55.ttf before...

Did you install "native rich text support 30" and "gdi plus library" with Wine doors?
Parent - - By brunjes (**) Date 2008-08-28 00:06
I had tried your fonts (and they look great!) but with your fonts or with the defaults, the lack of <CR> is still there. Not so on Windoze though. it all points to a non-focus on Linux by the developers.

I'll be buying the first native Linux port of Rybka for sure -- hint hint. I would even pay full price AGAIN for Rybka 3 on Linux.  hint hint.

Parent - By Felix Kling (Gold) Date 2008-08-28 10:54
no, Aquarium for Linux is no good idea. It would take the same devlopment time as porting would be very difficult. Anyway, there seems to be a way to fix the problem, as on my system it works :)
Attachment: Bildschirmfoto-15.png (659k)
Parent - - By Felix Kling (Gold) Date 2008-08-28 10:59
Does you wine cfg look like this? (riched: Native, BuiltIn..)
Attachment: Bildschirmfoto-16.png (117k)
Parent - - By brunjes (**) Date 2008-08-28 13:26
Not quite the same. How did you get those extra libraries to show up?

Here is mine:

msi (native builtin)
msiexec (native builtin)

I cannot see how to attach a screen shot, but those are the two libraries listed in my winecfg.

Parent - - By Felix Kling (Gold) Date 2008-08-28 13:32
aha, go to Wine doors and install them! (rich text edit..., gdiplus)
Parent - By brunjes (**) Date 2008-08-28 16:17
You are the man!!!


Excellent! Thanks so much for working with me to get this fixed!

Parent - By Felix Kling (Gold) Date 2009-03-29 21:18
running Rybka x64 with Aquarium with the netchess trick works fine :)
Parent - - By nine castles (**) Date 2009-05-20 13:24
Hey Felix. I can report that Aquarium runs very well with the latest development version of wine (1.1.21) under ubuntu 9.04. I have one question for you though. I am trying to import my ChessBase Megabase 2008 into Aquarium so I can focus on only one interface in Wine but still get access to the huge database that I already paid for. However this just locks up Aquarium and it becomes unresponsive. Is there some particular way I should be doing this? Is it even possible?
Parent - - By Felix Kling (Gold) Date 2009-05-20 13:44
It is possible. But what you want to do is saving the database as cdp and not as dsn (dsn is slow). So you need to open the mega database and then click on "save as new base" in the "home - list" category. it should work but take a lot of time (be prepared to let your computer run for one day or more).

I managed to import it by first saving all the commented games as pgn and then import them into aquarium. Then I also created a tree from those commented games so that all the comments from the database are displayed in the tree. But the method discribed above should also work.

Btw., do my Linux fonts work on your Ubuntu with the latest Wine? I have the problem that the font is rather ugly (like under Windows) when I update to the latest version.
Parent - - By nine castles (**) Date 2009-05-20 14:46 Edited 2009-05-20 15:00
I'll try that and report back, thanks. Chessbase also works very well in wine so it should be easy, but I'll have to reinstall it. :)

Everything looks pretty good; the only problem I've been having is that analysis is displayed all on the same line, rather than new PVs being appended to new lines.
Parent - - By Felix Kling (Gold) Date 2009-05-20 15:07
look at the FAQ above (question 2). Riched30 is the key :)
Parent - - By nine castles (**) Date 2009-05-20 19:44 Edited 2009-05-20 19:50
Ahh. I had that installed already, presumably since I did it when I first installed Aquarium according to this post :) So I was puzzled that it still wasn't working. But since I was in wine-doors I uninstalled and reinstalled the package and now it's sorted. Woo!

Here's another question: When running Idea, every time it pops up a processing notification, Aquarium steals focus, which means its impossible to run IdeA while doing some other task. Other functions like game analysis will do this occasionally, but none as often as IdeA. Can that be fixed?
Parent - - By Felix Kling (Gold) Date 2009-05-20 20:57
are you sure you installed the latest Aquarium? I think it was changed in some verion. But I'm not sure about it.
Parent - By nine castles (**) Date 2009-05-21 04:59 Edited 2009-05-21 05:02
No I didnt! Hah, sorry for the stupid questions :(

I let Aquarium run overnight importing the database and it seemed to be working, but it's horrendously slow when searching. I'll try your method next, as I'm going out of town for a couple days.
Parent - By Felix Kling (Gold) Date 2009-05-24 14:14
Btw., i just found out that the microwine trick via netchess works on english Ubuntu systems only. So if you can't connect to your local netchess engine, just change the language to english :)
Parent - By nine castles (**) Date 2009-05-25 17:13
I'm getting a lot of regressions with Wine 1.1.22, including Chessbase and Aquarium. I think people ought to stick to 1.1.21 as the best wine version for now.
Parent - - By Xaggard (**) Date 2009-06-21 06:41

I wonder what's wrong with my fonts? :( I can't change them by Settings -- Display settings...

P.S. My system now is ubuntu 9.04 x64. I installed LinuxFonts
Parent - - By Felix Kling (Gold) Date 2009-06-21 10:10
OK, two possible reasons:

-You need to make the font files write protected since Aquarium tries to replace them
-You need Wine 1.0 (the standard for Ubuntu) - some later versions have display problems for Linux fonts

I'll add them to the FAQ above, forgot about that.
Parent - - By Xaggard (**) Date 2009-06-21 16:37
But Wine 1.0 can't manage Fritz 11 and ChessBase 10 properly :(
Parent - - By Felix Kling (Gold) Date 2009-06-21 16:46
oh, yes, that's also true. maybe you can test some later versions, I'm not sure since which version the font didn't work anymore. Try to find the latest version of Wine where the font works and then test if it can start fritz/chessbase 10, too.

Btw., does Fritz 11 really work with the latest Wine version? I mean is the menu usable?
Parent - - By Xaggard (**) Date 2009-06-21 16:56 Edited 2009-06-21 16:59
I have installed wine 1.1.23, Fritz 11/CB9 works perfect!! Almost as in Windows!
One more bug in Aquarium under ubuntu 9.04 x64: after minimizing Aquarium window I have problems to maximize it back :( Aqua-window stays minimized so I always need to close programm and restart it again.
Parent - - By Felix Kling (Gold) Date 2009-06-21 17:18 Edited 2009-10-20 18:54
confirmed, as a workaround you could move the window to another work space or minimize it by dubbleclicking on the entry in the opened programs bar.
Parent - By Xaggard (**) Date 2009-06-22 15:44
BTW I tried wine 1.1.24 and 1.1.21 - they both caused some bugs during Fritz 11 work.
So I recommend using 1.1.23 for now
Up Topic Rybka Support & Discussion / Aquarium / Aquarium under Linux (FAQ)
1 2 3 Previous Next  

Powered by mwForum 2.27.4 © 1999-2012 Markus Wichitill