Not logged inRybka Chess Community Forum
Up Topic Rybka Support & Discussion / Rybka Support / Windows update Corrupted Rybka4 - two dll files corrupted
- - By Texture3 Date 2017-11-19 18:14
After last Tuesday 11/14/17 's Windows update RYBKA4 doesn't start and gives me an error message with respect to two .dll files: Texture3 and TBAcess.
When looking at those two files they were rewritten at the two of the update and both are 0 KB in size. opening up one in Notepad shows no content.

1 Tried uninstalling the software with the installation disk - nothing happened. ( Did not deactivate - do I need to do that first?)
2. Tried uninstalling with Windows Control Panel to remove Programs. Also nothing happened. ( Did not deactivate - do I need to do that first?)

3. Tried repairing the program with the installation disk and also nothing happened. ( Did not deactivate - do I need to do that first?)

At the present time the program is still activated.

Would appreciate help on this. Probably all I need is a good copy of those two dll files.

Parent - By Fulcrum2000 (****) Date 2017-11-19 21:19
Maybe check with Chessbase, those two files belong to the GUI not to the engine.
Parent - - By Texture3 Date 2017-11-23 19:26
Does anybody have a solution to this. Unable to install the program whether using the Original Disk or Windows Control panel for adding removing Programs.
Parent - - By Labyrinth (*****) Date 2017-11-23 23:04
What is the actual error you're getting? If it's an "Error opening file for writing." error it indicates a security/permissions issue.
Parent - - By Texture3 Date 2017-11-24 06:49
The Windows error message says that Texture3.dll and TBAcess.dll are not Windows files or are corrupted. It then suggests reinstalling the program ( meaning RYBKA4). However I can't uninstall the program. I have tried uninstalling the Program using the Original RYBKA4 installation disk, tried going into Windows File Explorer and using the setup.exe in the RYBKA4 folder and also tried uninstalling using Windows Control Panel as an administrator. All three methods fail.

The RYBKA4 installation disk also has an option to repair the program RYBKA4. Tried that also. Doesn't repair.

The problem is that I must have left RYBKA4 up and running over night when the Windows Update procedure ran and closed down my computer presumably corrupting those two dll files. The two dll files have no content - only a file name and zero size. Comparing it to another Chessbase directory I have on the same computer that directory has those two files with content. They are not large files but there is something in them.

Parent - - By Labyrinth (*****) Date 2017-11-24 07:00
Can you screenshot this error?

Does the cd have the option to install again?
Parent - - By Texture3 Date 2017-11-24 16:51 Edited 2017-11-24 18:20
Attachment: Install.jpg - Have tried the Repair and the Remove - initially as activated and then unactivated (172k)
Attachment: Texture3.jpg - Error -- same error box for the other dll (490k)
Parent - - By Labyrinth (*****) Date 2017-11-24 22:11
I actually found TBaccess in a copy of Fritz 8, so you might have another newer copy somewhere. Not sure what texture3 refers to, must be unique to those versions. Can someone just send him a copy of that dll?

Otherwise what happens when you click on modify? Does it let you reinstall things?
Parent - By Texture3 Date 2017-11-25 00:20 Edited 2017-11-25 05:01
I thought that was going to be right answer - just get a copy of those two files and copy them over. Your TBAccess worked with eliminating one error message. then I copied aTextures.dll in my Deep Fritz 8 folder, renamed it to Texture3.dll and that got rid of the second error message.

But then I got a new error message "The procedure entry TBMemMD could not be located in the dynamic link library <pathname to folder>.  So this looks like this is going to be going down a rabbit hole finding error after error. But I appreciate your help and hope you had a good holiday.

Re selecting 'Repair" or "Remove" in both cases the program just closes itself without doing anything. Selecting Modify and making selections I get  a new error message that the Program can't find C:Windows\fritzcc9d.ra

Bottom line I just need to somehow get it off the computer - and hopefully then it will install.

All this time I was thinking I was running the uninstall process off the installation disk - but no it points to the setup.exe file it put in the RYBKA directory(folder) and runs from that. We means if something gets corrupted on the hard drive then it means that one is out of luck.

The only recourse now seems to be to go through Windows Regedit and strip it out of there but I  don't have that expertise.
Parent - By RFK (Gold) Date 2017-11-25 06:59 Edited 2017-11-25 07:07
Go into control panel.
Appearances and Personalization
File Explorer Options
open file explorer
(click) View
Show hidden files, folders, and drives.
(click on that box)
Click ok!
Go into Windows C: open it - to user! click on your computer name. Not pub or default !

Go to AppData ( click on it ) Click on Temp and clean it out. Go to " Roaming " Microsoft " click on it !
Click on Windows!
"Recent" just delete contents. I don't even bother to open it. But sometimes you won't find "delete" in the scroll down.

Chessbase is proprietary before reinstalling make sure you follow the " How to Uninstall ChessBase - Step by Step Guide to Remove Unwanted program Completely with the perfect Uninstaller" and then reinstall.

To more option go back to " up arrow" and back to " local" click on Chessbase! read through the docs and see if you find an error - but if you uninstall go in here and delete this folder after you followed the above chessbase guide!!!! Otherwise you might end up with the same problem all over again!
Up Topic Rybka Support & Discussion / Rybka Support / Windows update Corrupted Rybka4 - two dll files corrupted

Powered by mwForum 2.27.4 © 1999-2012 Markus Wichitill