Not logged inRybka Chess Community Forum
Up Topic Rybka Support & Discussion / Rybka Support / Rybka 4.1 SSE42 x64 hangs after saving >2GB hash file.
- - By yorkman (**) Date 2012-12-19 02:59
I don't know why but if I analyze with this engine and try to do a hash file save during infinite analysis I can see the file in the directory is always 0 bytes instead of 4 GB. If I change the hash file size to 2 GB it saves fine and the engine continues analysing. But if I set it to greater than 2 GB the engine hangs if I do a hash save. I can click STOP in Aquarium 2012 but that takes about 5 mins before it actually stops.

When I use Houdini 3 in Aquarium 2012 and try to save a hash file that's 8 GB it works fine. I have 16 GB of ram and Win'7x64 so that should not be a problem. And I've tried this on two different pc's (the other is XP64 with 16 GB of ram).

Any ideas?
Parent - - By jenniferjohansoon [pk] Date 2013-01-29 04:38
Manual exists (I know because I wrote the unofficial "documentation"), so I guess Keoiki was pointing out to Aquarium and Chess Assistant's Manuals.
World, you're gonna have´╗┐ to end later. I have plans.
Parent - - By yorkman (**) Date 2013-09-17 14:19 Edited 2013-09-17 14:54
Sorry for such a late reply. I didn't see your reply until now when I googled this problem again. I basically stopped using Rybka 4.1 then but now I wanted to try it again and I'm still having the same problem across all my pc's. I checked whatever documentation I could find and I don't see why this would be a problem, at least in Aquarium (any version). I don't use Chess Assistant.

I'm using Rybka 4.1 SSE42 x64.exe.
Tried using a pagefile and no page file. Saving to hash N:\ which is my SSD drive (NTFS) (tried other locations too). If I set the hash back to 2GB it saves fine and R4 continues to analyze. If I set it to 4GB or higher it just hangs...the hash file is created by it's locked at 0 bytes. I then have to wait about 3 mins before I can unload the engine and/or close Aquarium (hash file is then unlocked and I can delete it afterwards).

I don't have this problem with Houdini, even 8 GB hash.
Parent - By keoki010 (Silver) [us] Date 2013-09-17 15:58
Try editing aquariumData>config>RplayOptions.xml and set     <TreeOptions tree_memory="1000"/>

It is probably set to 500 now.  NOTE:Aquarium must not be active running when you edit it.
Up Topic Rybka Support & Discussion / Rybka Support / Rybka 4.1 SSE42 x64 hangs after saving >2GB hash file.

Powered by mwForum 2.27.4 © 1999-2012 Markus Wichitill