Not logged inRybka Chess Community Forum
Up Topic Rybka Support & Discussion / Rybka Discussion / Rybka 3 on Linux: excessive disk I/O?
- - By brunjes (**) Date 2008-08-08 13:26
Anyone else seeing anything like this?

I purchased Deep Rybka 3 Aquarium. I installed it via wine on my Ubuntu 8.04 64-bit system. I start Aquarium and things seem OK so far. I then click on Sandbox and then click Analyze and things seem OK. My dual core system sees both cores running at full speed. Of course, hash is set to the default 32 MB. I see about 40 kn/s on my system (no, this is not about how low the kn/s is -- I know that Rybka 3 has much lower numbers in this department).

Now, I click on Setup to change the engine hash size and set Rybka 3 default (the engine I'm using for this test) to use 512 MB of hash (I have 3 GB of physical RAM on my system so this is not a problem). I then go back to Sandbox and click Analyze and a TON of disk I/O starts up and never ends. Rybka engines never get more than about 30% of the CPU and mount.ntfs sees the most CPU usage. My Gnome System Monitor shows very heavy disk writes happening continuously. It is not swapping as total memory use is 857 MB.

The engine never has the chance to get to any real depth as the I/O dominates the use of system resources.

If I exit Aquarium and go back into it and just click Sandox and Analyze, it still behaves this way.

Does this have anything to do with Persistent hash (which I've not touched yet)?

Thanks for any advice you can give.

Roy
Parent - - By boo! (**) Date 2008-08-08 13:40
I had the some i/o-issues running rybka through wine on Ubuntu 8.04. These problems went away using the new microwine(http://rybkaforum.net/cgi-bin/rybkaforum/topic_show.pl?tid=5778) to run Rybka 3.

In addition, wine only supports 32-bit applications, so I would guess Aquarium fires up 32-bit rybka when running in wine.

Using microwine, you'll be able to run the 64-bit version.
Parent - - By brunjes (**) Date 2008-08-08 13:52
What GUI are you using to run the 64-bit Rybka-3 under? I tried SCID 3.6.25 (not yet released) and it crashes when I try to start it.
Do you run Aquarium with microwine??

Thanks,

Roy
Parent - - By boo! (**) Date 2008-08-08 14:12
I use http://jose-chess.sourceforge.net/ to run rybka. This is a java GUI.

Starting a native process(e.g. microwine) from Aquarium in wine could perhaps be done in some way, but it would probably require a hack. I have little experience with wine and don't know how much it knows about the world outside it's emulated M$-OS.
Parent - - By Vempele (Silver) Date 2008-08-08 14:13

> I have little experience with wine and don't know how much it knows about the world outside it's emulated M$-OS.


You can run a Linux binary and get its return code, the instructions don't cover anything else.
Parent - By boo! (**) Date 2008-08-08 14:28
Using the network stack would probably be the easiest way then. I belive a saw a network proxy for chess engines once. I'm not sure though. Writing such a utility wouldn't be very hard anyway.
Parent - - By Sesse (****) Date 2008-08-08 20:15
Well, from basic testing it seems like you can just run a Linux binary as any other binary, as long as the filename ends in .exe. I don't know whether stdin/stdout are connected, though -- it's sort of hard to test.

I've got a microwine version with some hacks for running inside WINE; if anybody has a 64-bit machine with a Windows GUI running under WINE, they could get a test version, I guess.

/* Steinar */
Parent - - By galaxy07 Date 2008-08-09 16:45
Hi!
I would like to have the test version of microwine for running under WINE!
Thanks!
BTW: why don't you make it publicly available?
Parent - - By Sesse (****) Date 2008-08-09 18:58
It's not released because it's not ready for that yet, but you can try http://storage.sesse.net/mw-test-0.9 and see if it helps.

/* Steinar */
Parent - - By galaxy07 Date 2008-08-09 23:14
Thanks!
That doesn't seem to work now, though:
dima@dima-laptop:~/.wine/drive_c/Programme/ChessBase/Engines$ wine microwinedRybka3.exe
wine: could not load L"C:\\Programme\\ChessBase\\Engines\\microwinedRybka3.exe": Fehlerhaftes EXE-Format f�r
Parent - - By Sesse (****) Date 2008-08-10 11:30
You cannot run it from WINE itself. You'll need to get a Windows program under WINE to start it.

(If you wonder, this is part of the reason why it's not released yet -- it's a lot easier if I can get someone who thinks approximately like me to test it, so I won't have to explain such things :-) )

/* Steinar */
Parent - By galaxy07 Date 2008-08-10 14:07
ok, sorry to bother you!
It didn't start in the interface, that's why I tried it with WINE.
But if you don't want me to test, I will wait for the official release!
Parent - - By brunjes (**) Date 2008-08-08 14:35
I downloaded and installed Jose. Any way to make those hideous fake marble squares something nicer? It's horrible to look at and the options screen shows about 10 other choices (all of which are terrible).

64-bit Rybka-3 does indeed run under Jose though!

Thanks,

Roy
Parent - - By brunjes (**) Date 2008-08-08 14:41
I have to take that back now. After running it fine for a bit with defaults, when I change hash table size to 512 MB, the engine does not run anymore. This is eerily similar to my situation when I ran under Aquarium and changed hash to 512 MB and things went sideways.
Now, Jose gives me a bug report popup when I try to start infinite analysis with Rybka (64-bt in this case).:  "An unexpected error has occurred..."

Sigh.

We need native Linux version of Rybka 3!!!
Parent - By boo! (**) Date 2008-08-08 14:48
This crash is probably caused by the default value of /proc/sys/kernel/shmmax beeing too small.

Try doing a (echo 600000000 > /proc/sys/kernel/shmmax) as root.

(this is described in the microwine README)
Parent - By boo! (**) Date 2008-08-08 14:49
Haha :)

I didn't say it was a looker, I said it worked :)
Parent - - By giorgio Date 2008-08-09 06:21
Hello Roy,

I don't have Rybka 3 so I can't help you directly, but I've just commited a change in SCID 3.6.25 to get a log file of the scid-engine communication even just after a crash.

So, please, could you get the latest version of SCID and try to execute Rybka 3 from it?
Then, after the crash, you should find the log file in /your_home_directory/.scid/log/engine1.log
Could you please post here that file or send me it directly to gbellegotti@tin.it ?

In my opinion SCID sends some UCI command that other GUIs don't.
I hope to understand which UCI command causes the crash and to reproduce it with stdin/stdout, so maybe Sesse can fix it in microwine.

Bye.
Parent - By brunjes (**) Date 2008-08-09 06:57
Giorgio,

I'll get you the log file early tomorrow (after a bit of sleep -- getting late here).

Thanks for your help in trying to get SCID working with Rybka 3!

Roy
Parent - - By Vasik Rajlich (Silver) Date 2008-08-08 18:41
This is unrelated to persistent hash. You are swapping to disk (for some reason).

Vas
Parent - - By brunjes (**) Date 2008-08-08 18:58
Vas,

I have to disagree. Even with 128 MB of hash tables, this behavior results. And the Linux free command shows I have 0 bytes of swap space used, so it is not swapping that's happening.

I'm reloading my 32-bit Ubuntu on a PC I have to see if the problem is related to 64-bit Linux being present.

Roy
Parent - - By Vasik Rajlich (Silver) Date 2008-08-08 19:26
Ok.

Vas
Parent - By brunjes (**) Date 2008-08-08 19:45
I loaded Ubuntu 8.04 LTS 32-bit on one of my PCs. The behavior is STILL there.

I wiped out Aquarium and reinstalled it too. No difference.

Here is the strange thing:

The very first time I run Aquarium, things work fine. It's only after I exit Aquarium and restart it that the heavy disk I/O starts in when I try to run Rybka-3.

I'm open to suggestions.

Roy
Parent - - By Zruty (*****) Date 2008-08-08 19:43
Maybe it's Aquarium's heavy IO writes, not Rybka's? This may be verified if you run Rybka under another GUI or with no GUI at all, entering the UCI commands yourself. You'll need something like

uci
setoption name Hash value 512
position startpos
go infinite
Parent - - By brunjes (**) Date 2008-08-08 19:47
Zruty,

This also happens under ChessBase GUI (Shredder 8).

Roy
Parent - By Zruty (*****) Date 2008-08-09 07:42
So I think it's not an Aquarium issue, and it's not my work :)

I still suspect Rybka starts swapping to disk. I think you should try to monitor, WHO does all this IO.
Parent - - By Felix Kling (Gold) Date 2008-08-09 21:49
You wrote that you have 1 GB of rams, so 256 MB is the setting you should use. Even if it's not displayed, 512 MB will be too much for your system!
Parent - By brunjes (**) Date 2008-08-10 03:48
I have two systems, one with 1 GB RAM (and 256 MB would be fine for that, but only 32 MB or less avoids the excessive disk I/O), and one with 3 GB RAM. The 1 GB system has been downgraded to Ubuntu 8.04 32-bit while the system with 3 GB of RAM has Ubuntu 8.04 64-bit (still). If I could get to 1 GB of RAM for hash on the 3 GB system, I'd be happy, but I cannot even get to 512 MB there.

I'm hoping there is a patch to wine (for what exactly, I don't know because I cannot pin down what is actually happening with Rybka 3) or a change gets made to Rybka 3 to make it not do this -- eventually of course.

In the mean time, how much does 32 MB of hash hurt the performance of Rybka 3 compared to 256 MB? There used to be debates about this years ago where each doubling meant 8 ELO or something like that -- does that still apply to today's hardware and super strong software?

Roy
Up Topic Rybka Support & Discussion / Rybka Discussion / Rybka 3 on Linux: excessive disk I/O?

Powered by mwForum 2.27.4 © 1999-2012 Markus Wichitill