Not logged inRybka Chess Community Forum
Up Topic Rybka Support & Discussion / Aquarium / Aquarium under Linux (FAQ)
1 2 3 Previous Next  
Parent - - By D.Esser [de] Date 2009-09-17 18:35
Hi Felix,

just try to migrate from Aquarium under Vista to Aquarium under Ubuntu 9.04 64 Bit.

Installation of Aqarium via WINE works without problems, but when I start Aquarium I get a weird screen



Tabstrips at the top are missing, and there is no chessboard. Any clue what happens here?

Greetings
Dieter
Parent - - By Felix Kling (Gold) [de] Date 2009-09-17 18:52 Edited 2009-09-17 18:56
Try this:

Also make sure you use Wine 1.0 or 1.01, don't know if there are problems with Wine versions other than the standard version that comes with ubuntu 9.04, and check if you installed the packages I mentioned in the first post of this thread with winetricks.

Did you run the normal installation or did you copy some files from the windows installation manually?

What happens if you want to change e.g to sandbox mode?
Parent - By D.Esser [de] Date 2009-09-18 09:51
Hi Felix,

I'm running WINE 1.01, Restore to Default (or any other action) didn't change the behaviour. When I change to sandbox or to any other object my main screen part is still empty.

I've installed Aquarium with the normal setup routine without copying anything from the windows folders. I've installed Arena 2.01 parallel and it works without a flaw, but unfortunately the 64-bit rybka doesn't work under Arena (and I missed the analyzing capabilities from Aquarium).

Greetings
Dieter
Parent - - By Sesse (****) [ch] Date 2009-11-01 00:32
By the way, the package is called msttcorefonts, not mstcorefonts :-)

/* Steinar */
Parent - By Felix Kling (Gold) [de] Date 2009-11-01 00:34
:)
Parent - - By tipau [gb] Date 2010-12-19 16:23
Hi,

I'm having trouble with the coordinates & clock appearing as chess symbols.
I went to install the ttf-mscorefonts-installer package (as advised in the FAQ) but get the message "ttf-mscorefonts-installer package is already the newest version" - so I guess the problem must be with something else?

I'm using wine 1.3.9 and ubuntu 10.10 if that makes any difference?

Tim
Parent - - By Felix Kling (Gold) [de] Date 2010-12-19 18:44
Well, I had the same problem some days ago, too (using a laptop). Try reinstalling the ttf-mscorefonts-installer package!
Parent - By tipau [gb] Date 2010-12-19 19:03
Reinstalling has done the trick. Thanks!
- - By nine castles (**) [us] Date 2009-09-18 09:33
Felix, have you heard of PlayOnLinux? Might this be a way to make 64bit installation easy for Linux users?
Parent - - By Felix Kling (Gold) [de] Date 2009-09-18 10:42
does it support 64 bit? afaik it's just based on wine?
Parent - - By nine castles (**) [us] Date 2009-09-18 18:09
It is a frontend for wine, but it has some other benefits: it allows you to execute authored scripts to install fonts, extra packages, &c or whatever else might be necessary for your program to work. I looked at your instructions and though I don't have much experience with shell scripting it looked like most of that could be executed from the command line. That might make it simpler for Rybka customers, if you could simply offer a POL script to install Aquarium, Microwine/netchess, and the necessary fonts without trouble.
Parent - - By Felix Kling (Gold) [de] Date 2009-09-18 22:50
ehm my scripting knowledge isn't better than yours :)
Parent - By nine castles (**) [us] Date 2009-09-19 06:09
Maybe not, but perhaps something could be cobbled together through trial and error. :-) I'll give it a shot, my Aquarium install is broken anyway.
- - By sdd (*) [gb] Date 2010-02-07 09:58
I am unable to create a new database in Aquarium 4.0.2 & wine 1.0.1. Any suggestions?

I get the dialog box, give it a name and click 'save'. The dialog box closes and nothing more happens. I have tried it under XP and it works fine.
Parent - - By keoki010 (Silver) [us] Date 2010-02-07 17:24
Do you have a database open with CA that has the same name?  Close it and you can create another one in a different directory.
Parent - By sdd (*) [gb] Date 2010-02-07 19:58
No - I am creating a new database with a new name. Nothing happens when I do it under wine.

Everything else seems to work properly - I can save to a different type of database (though to do 1,000,000 pgn games to a CA database was taking about 12 hours!).
Parent - By Felix Kling (Gold) [de] Date 2010-02-13 15:24
mmh, confirmed. There should be several workarounds such as selecting one game in an existing database and use the "save as new base" button. Then you can delete the game there and have a new blank database.
Parent - By Master Om (Bronze) [in] Date 2010-05-06 00:14
migrate to windows.
- - By nine castles (**) [us] Date 2010-02-08 03:35
Is it completely out of the question to use a rybka-native made with microwine and link it up with aquarium book adapter/arena? I am really enjoying my Rybka setup for online play (FICS) with Arena on Windows, but I prefer linux for everything else and would like to have the best of both worlds. Is this feasible at all?
Parent - By Felix Kling (Gold) [de] Date 2010-02-13 15:19
It's no difference - you just follow the instructions here: http://rybkachess.com/index.php?auswahl=Linux and then install the netchess engine in the adapter. That's it.
- - By sheva [gr] Date 2010-02-13 14:03
Thank you this was the most usefull thread about rybka aquarium and linux.
There was no need to search for hours to solve the problems.
Parent - By Felix Kling (Gold) [de] Date 2010-02-13 15:19
:)
- - By icebox (**) [it] Date 2010-05-04 09:29
With Ubuntu 10.04 and wine 1.1.43, Aquarium works fine.

Regards,
IceBox
Parent - - By Felix Kling (Gold) [de] Date 2010-05-04 13:10
any font problems? I experienced some when testing, the fonts looked ugly... I switched back to Wine 1.0 therefore (still in the ubuntu repos). could you post a screenshot?
Parent - By icebox (**) [it] Date 2010-05-25 09:25
Felix, I am sorry for the replay delay.

I had not any issue about the fonts.

(I installed now 1.2 release candidate).

Regards,
IceBox
Parent - - By icebox (**) [it] Date 2010-05-27 20:18
With Wine 1.2-rc1 and Aquarium 4.0.3 build 234 it works nice on Ubuntu 10.04.

Thanks for your efforts,
IceBox
Parent - By Felix Kling (Gold) [de] Date 2010-05-27 20:22 Edited 2010-05-27 20:24
my concern is always the font. Maybe you could attach a screenshot? With my font and Wine1.0 it looks fine, but either with the standard font or my font it looks a bit worse on my ubuntu 10.04 with wine 1.2.
Parent - By Master Om (Bronze) [in] Date 2010-05-06 00:16
it has problem with UTF-8 code.
- - By icebox (**) [it] Date 2010-05-29 08:44
Aquarium 4.0.5 with Wine 1.2rc2 works nice.
Attachment: Aquarium_4.0.5_Wine_1.2rc2.png - Aquarium 4.0.5 with Wine 1.2rc2 (148k)
Parent - - By Felix Kling (Gold) [de] Date 2010-06-06 11:25
Indeed, it looks all well.

I removed my fonts, they are not needed anymore.
Parent - By icebox (**) [it] Date 2010-06-06 12:58
Nice. :) And it works out-of-box. I used "only" note #2 in your first post.

Regards,
IceBox
- - By gregor (**) Date 2010-10-24 12:33
I can report that Aquarium 4.0.5 runs nearly 100% under ubuntu 10.10 and wine 1.2.1.
Only manually installed riched30 with winetricks to get that carriage return in analysis.

Minor issue: when opening a new "window" , eg. a graph the tab appears but window content is not automatically updated (also after changing tabs). Need to maximize and restore window to get the window content. But don't know if this is a Linux issue?
Parent - - By Felix Kling (Gold) [de] Date 2010-10-24 21:28 Edited 2010-10-24 21:31
You mean that if you change the evaluations in the notation the graph is not updated? That's normal. The graph is created when the graph window opens. The graph when you watch engine tournaments is updated automatically for example.
Parent - - By gregor (**) Date 2010-10-25 17:25
No.
After selecting "Graph" the "Graph" tab is highlighted in one window but still the header window is displayed.
Switching between "Header" tab and "Graph" tab will not change the window's content, still header information displayed, although tabs are highlighted and window title bar changes accordingly.
Only after maximizing and restoring the window the graph is actually visible. And from then onwards the tab switching works fine.

Sounds more complicated than it is :confused:
Parent - - By Felix Kling (Gold) [de] Date 2010-10-25 18:02
ah, now I understand. That only happens if you have merged two tabs. If you separate them by drag&drop, the problem disappears.
Parent - By gregor (**) Date 2010-10-25 18:21
Got it. Thanks.
- - By yorkman (**) Date 2016-10-22 20:01
I hope I can still use this thread seeing as it's so old but it has been edited recently...

I installed Aquarium 2015, and also tried 2016 and while they install fine both show me the aquarium splash screen and then just crashes with an "access violation at address" error.

Any ideas on what I'm missing? I've installed wine and had the same error so after I installed wine64 but no difference. Using Ubuntu 15.1.

Parent - By Felix Kling (Gold) [de] Date 2016-10-22 22:06
mmh, strange. Can you append the complete eureka log (that is mentioned in the error)?

Btw., Aquarium 2016 has some serious problems with trees, so please try only Aquarium 2015, which should run.

Did you install riched and so on as recommended in the text at the top of this thread?
Parent - - By Felix Kling (Gold) [de] Date 2016-10-22 22:07
and I assume you installed Aquarium 32 bit (not 64! you can select it during installation)?
Parent - - By yorkman (**) Date 2016-10-22 23:28 Edited 2016-10-23 00:00
Yes I saw the edited thread that Aquarium 2016 doesn't work well hence why I also tried Aquarium 2015 but same error.

Does Aquarium 64bit not work in wine? That's what I selected so I'll try 32bit, but I figured it'd give me less than optimal performance.

Will my x64 bmi2 SF/H4/K10 engines work as 64bit in Aquarium 32bit? I assume yes since I'm still using 64bit OS...do I install Wine 32 or 64bit?

I didn't know where to get or how to install riched30 so I'll google that. I assume it'll be something like apt-get install riched30. Btw, I tried first installing Wine as per this site (below) but it didn't say if it was 32bit. But further down it says how to install Wine 64 so I installed that too. I couldn't figure out how to properly uninstall the first Wine so I left it. I'm going to reinstall Ubuntu 16 this time to start clean and take a snapshot. Right now I just want to know how to get this working via Vmware workstation but the main goal will be to migrate my Aquarium 2016 to Ubuntu. That's not going to be easy since it doesn't work well in Ubuntu. I'm hoping I can install 2015 and just copy the database and config files.

http://ubuntuhandbook.org/index.php/2015/12/install-wine-1-8-stable-new-ppa/

Btw, I appreciate your assistance in this matter.

EDIT: I installed Ubuntu 16 and did everything the same except install Aquarium 2015 as 32bit. Works fine now. Just concerned that performance won't be that great. I wonder how hard it'll be to migrate from Aquarium 2016 (Windows).

Btw, should I be using the .exe's for the engines or compile the engines if it has the source? I never compiled an engine in Linux. I don't think I need mingw anymore. I think for asmFish though I'll have use the .exe since I don't see how I can compile that.
Parent - - By Felix Kling (Gold) [de] Date 2016-10-23 01:26
first of all, there is no big difference between 32 and 64 bit for the GUI. You can still load 64 bit engines and there is absolutely no reason to be worried.

about riched installation: use winetricks: run winetricks in terminal, a GUI opens, select "change current wine prefix" (or something similar), then "windows dll" and a list opens.

for engines: easiest is using the exe. you can use native engines, but this requires some tricks: http://rybkaforum.net/cgi-bin/rybkaforum/topic_show.pl?pid=568025
performance is about 5-10% better if using native engines. And you don't need to compile the engines yourself, there are binaries that work for linux if you want a native engine.

and yes, I never managed to run the 64 bit aquarium, but 64 bit wine is rather new and it's no big surprise. just use 64 bit wine so you can run 64 bit engines.
Parent - - By yorkman (**) Date 2016-10-26 01:38 Edited 2016-10-26 01:46
I installed the 64bit version of Aquarium and ran it with wine64 but it still crashed. The only way it works is installing Aquarium 32bit and using wine instead of wine64 to load it. One issue I have is the notation window. When the notation is full of multiple nested lines and variations, each line is indented so the more your scroll down the more of the notation disappears to the right (off the window). Kind like opening notepad without word wrap. But there's no scroll bar in the notation window so it's basically impossible to see your lines. One workaround is to open the notation window as floating and then maximize it. See below:



So there's a scroll bar on the right but the bottom one is missing. Using the cursor keys for each move also doesn't work because nothing in the notation window changes.

Anyway, tough to work through that but still do-able. My main issue now is compiling and getting my engines to work in Ubuntu via Aquarium 32bit. Here I'm trying to compile cFish. See below:

It starts compiling but then I just get:

sudo make profile-build ARCH=x86-64-bmi2
make ARCH=x86-64-bmi2 COMP=gcc config-sanity
make[1]: Entering directory '/home/ac/Cfish-master/src'

Config:
debug: 'no'
optimize: 'yes'
arch: 'x86_64'
bits: '64'
prefetch: 'yes'
popcnt: 'yes'
sse: 'yes'
pext: 'yes'

Flags:
CC: gcc
CFLAGS: -Wall -std=c11 -pedantic -Wextra -Wshadow -m64 -DNDEBUG -O3 -DIS_64BIT -msse -msse3 -mpopcnt -DUSE_POPCNT -DUSE_PEXT -mbmi2 -march=native -DNUMA
LDFLAGS: -lm -Wl,--no-as-needed -lpthread -lnuma -Wall -std=c11 -pedantic -Wextra -Wshadow -m64 -DNDEBUG -O3 -DIS_64BIT -msse -msse3 -mpopcnt -DUSE_POPCNT -DUSE_PEXT -mbmi2 -march=native -DNUMA

Testing config sanity. If this fails, try 'make help' ...

make[1]: Leaving directory '/home/ac/Cfish-master/src'

Step 0/4. Preparing for profile build.
make ARCH=x86-64-bmi2 COMP=gcc gcc-profile-prepare
make[1]: Entering directory '/home/ac/Cfish-master/src'
make ARCH=x86-64-bmi2 COMP=gcc gcc-profile-clean
make[2]: Entering directory '/home/ac/Cfish-master/src'
make[2]: Leaving directory '/home/ac/Cfish-master/src'
make[1]: Leaving directory '/home/ac/Cfish-master/src'

Step 1/4. Building executable for benchmark ...
make ARCH=x86-64-bmi2 COMP=gcc gcc-profile-make
make[1]: Entering directory '/home/ac/Cfish-master/src'
make ARCH=x86-64-bmi2 COMP=gcc \
EXTRACFLAGS='-fprofile-generate' \
EXTRALDFLAGS='-lgcov' \
all
make[2]: Entering directory '/home/ac/Cfish-master/src'
gcc -Wall -std=c11 -fprofile-generate -pedantic -Wextra -Wshadow -m64 -DNDEBUG -O3 -DIS_64BIT -msse -msse3 -mpopcnt -DUSE_POPCNT -DUSE_PEXT -mbmi2 -march=native -DNUMA -c -o benchmark.o benchmark.c
In file included from settings.h:4:0,
from benchmark.c:30:
numa.h:7:18: fatal error: numa.h: No such file or directory
compilation terminated.
<builtin>: recipe for target 'benchmark.o' failed
make[2]: *** [benchmark.o] Error 1
make[2]: Leaving directory '/home/ac/Cfish-master/src'
Makefile:500: recipe for target 'gcc-profile-make' failed
make[1]: *** [gcc-profile-make] Error 2
make[1]: Leaving directory '/home/ac/Cfish-master/src'
Makefile:424: recipe for target 'profile-build' failed
make: *** [profile-build] Error 2

The missing files/folders are all there so I don't know why it's complaining.

I compile the same way in Windows and it's fine (albeit with MingW not gcc). Same errors even if I compile with root and without sudo of course.

Any ideas? Am I still supposed to use MingW instead of gcc in linux? Or how does it work?

Also trying to run asmFish.exe. I'm using the native one from 10-16 and it runs fine but 10-17 crashes. Most of the versions of asmFish I have tried just crash in Ubuntu:

Sorry for including too many separate issues in one message.
Parent - - By nebulus (****) [no] Date 2016-10-26 02:06
apt-get install libnuma-dev
Parent - - By yorkman (**) Date 2016-10-26 02:22
Nice! That solves the compiling of cFish issue. Problem is this engine won't install or run in Aquarium wine. I'm guessing I can't compile this way and that I need to compile with MingW so that I get an executable (.exe) otherwise I just get a cFish executable file.
Parent - - By yorkman (**) Date 2016-10-26 02:37
I saw that about 2 hours ago but didn't seem to apply to any of my issues. Are you talking about me uninstalling Ubuntu Desktop and just installing XUbuntu instead? I hope not, I like the look of Ubuntu desktop.
Parent - - By Felix Kling (Gold) [de] Date 2016-10-26 02:41 Edited 2016-10-26 02:43
this works with any ubuntu distro. checked with ubuntu gnome. still, the easiest solution is installing the 64 bit windows executables instead of compiling the engines on your system. at least with the usual stockfish I never had problems. Or use precompiled files and the inbetween trick.
Parent - By yorkman (**) Date 2016-10-26 02:56
I don't know why I'd have to use InBetween to compile an engine on linux for Aquarium. Nor do I want to use pre-compiled engines. I like to be able to, as I am in Windows, compile the engine. It gives me the opportunity to add/modify code. I was also able to add LP thanks to BYO. In Linux I feel handicapped. I can't do any of that. I used to use Linux all the time about 15 years ago but I've lost the touch or desire to figure things out now and spending hours on end. I'm too old for that now so I appreciate everyone's help here. And the whole point of me installing Ubuntu and dual booting with Windows is so that I can see if my engines will run faster in Linux and if not I just go back to Windows. But honestly I'm liking Ubuntu so I'd prefer to stay as long as I can still do everything in Ubuntu which was able to do in Windows. It doesn't look like I'll be able to do all that...at least not without spending many more days trying to resolve all issues....I think as long as I continue to get help I'll keep trying for a while longer.
Parent - - By Felix Kling (Gold) [de] Date 2016-10-26 02:42
did you use winetricks to install riched and so on as described in the top post?
Parent - - By yorkman (**) Date 2016-10-26 03:09
Having issues with that:

ac@ubuntu:~$ winetricks
/usr/bin/winetricks: 2201: /usr/bin/winetricks: cannot create /tmp/early_wine.err.txt: Permission denied
------------------------------------------------------
wine cmd.exe /c echo '%ProgramFiles%' returned empty string, error message 'wine: /home/ac/.wine is not owned by you'
------------------------------------------------------

.wine is owned by me.
Up Topic Rybka Support & Discussion / Aquarium / Aquarium under Linux (FAQ)
1 2 3 Previous Next  

Powered by mwForum 2.27.4 © 1999-2012 Markus Wichitill