Not logged inRybka Chess Community Forum
Up Topic Rybka Support & Discussion / Aquarium / Installing engines in another Aqr installation
- - By cma6 (****) Date 2020-09-21 00:18
I installed Aqr2020 on a different system. Everything transferred OK except engines.
I copied over engines.xml from the master system. On the new system, the \Engines folder is in the same relative path.
In the new installation, all the engines show up correctly. However, when I try to run any engine, it seems to start with a pale green icon but nothing happens. I have tried uninstall and reinstall engines but same thing happens.
Parent - - By Ghengis-Kann (***) Date 2020-09-23 14:29
Pale green means it can't connect.

Check to make sure the firewall isn't blocking the engines.

Also make sure you assign static IP addresses to the computers running remote engines in your router settings.
Otherwise it will dynamically assign them and they can change.
Hovering over the pale green box should show where it is trying to connect to.
Parent - By cma6 (****) Date 2020-09-25 18:54
GK, thanks for the ideas. I checked my firewall and anti-virus. Aquarium is Trusted. Stockfish is not listed, so I added it to allowed apps in Windows Defender and in my anti-virus but to no avail.
When I hover over the pale green square for SF, I see "SF 10091717 is starting and hash size is..."
Parent - By cma6 (****) Date 2020-09-28 20:35
Problem finally solved. Even though one doesn't always get the right answer from experts like you, your expert input is very valuable as it gets one to think about the issue out of the box.

You got me looking for issues like different firewall settings on a different system. Then I realized tha the "different system" has a much older CPU than in my master system. The older CPU can't use SF .bmi2 engine files but can use SF "Modern" engine files. Voila.
Up Topic Rybka Support & Discussion / Aquarium / Installing engines in another Aqr installation

Powered by mwForum 2.27.4 © 1999-2012 Markus Wichitill