Not logged inRybka Chess Community Forum
Up Topic Rybka Support & Discussion / Aquarium / Idea Project Problems
- - By RSeanOConnell (**) Date 2019-12-24 21:01 Edited 2019-12-24 21:05
But, now I have a new problem.  One of the projects I have is not writing to the tree.  I let it run all day and night yesterday.  Nothing.  It had been working fine until a few days ago.  Just noticed that the analysis results from other nodes is also not showing up in the tree.  They had previously.  WTF happened?

Also, one of my Idea Projects disappeared.  Maybe not the worst thing since I have it backed up but still frustrating.  I assume I just drop the backed up AQT file into the appropriate data file?

I am running AQ14 and haven't had any problems until this week.
Parent - - By pawnslinger (****) Date 2019-12-24 22:25
AQ2014 has bugs (well, all versions have bugs).  I upgraded to AQ2017 for this very reason... and it is pretty stable.

When things are not recording to your tree.... you should check over your setup.  Silly things, like have a funny spelling of a tree name (careful when using Eastern European names... they might have illegal filename characters in them).  Hard to predict what might be the cause... back in the day (when I used to play with things a LOT) stupid things I tried (and was told in this forum that I couldn't do... that the program wasn't meant to do what I was trying to do) disappearing trees and missing analysis were common problems.  But to help track it down, we need a LOT more information about what you were doing and the setup you were using.
Parent - - By RSeanOConnell (**) Date 2019-12-25 01:46 Edited 2019-12-25 03:15
This may be the reason I needed to upgrade.

I have several projects.  Most are the names of the openings I am working on.  Such as Modern - Bf4, Modern - Austrian Attack, Hippo, My Positions.

The project that was not writing to the tree is "Hippo". 

Project Description: Hippo
Project Type: Local
CPU usage: Active
Analysis tree: IDeA\Hippo.aqt (Box is checked for "The same as the project description")
Master Tree: Not Set
Root Positions: 9 root positions(s) - I have had many many more.  At some point I copy the position to a database "Opening Prep Black - 01, 02 etc." and add the Best line from Idea.  I then remove the root position.
Analysis quality: 1s AND depth 40, wait for next depth
Insert infinite analysis from linked games is checked
Queries to TB7 server is not checked
Min Time 300
Min Depth 40
Tree Configuration: Idea

I may have figured out what happened with that.  Somehow the box "Master Tree" in the Idea setup got checked.  I don't use a Master Tree.  Just the analysis tree which is the same as the project name.  In this case "Hippo".  Edit: This may not have fixed it.  Grr.

Could this have something to do with the tree configuration?  I haven't changed anything and have been using this setup for a few years with no problems.

But, if that is the case for my Hippo project it still doesn't explain why the project "My Positions" simply disappeared from the list.  Do I just copy the backed up version to the data file.  I assume the AQT file?

I appreciate your help in advance.
Parent - - By mattchess (**) Date 2019-12-25 03:17 Edited 2019-12-25 03:28
I notice you have it set depth 40.  This is a high depth for IDEA in my opinion.  I personally use depth 30 because I find I get to 30 depth in a reasonable amount of time.  I use IA to explore key/interesting positions to higher depth using different engines and then pass those lines back into the IDEA project.

That is just how I do it - others may have different opinions.  But IDEA is a balancing act between depth of analysis of a given position and expanding/exploring alternatives in a reasonable period of time.  I prefer to analyze key positions with IA myself and feed those lines back to idea at higher depth.

Once I think I am convinced of a candidate move based on idea I examine the lines with IA, just to be sure (you can use the tree functions in Sandbox mode to see the best tree lines) and if I think more expansion is needed I feed those back into the IDEA project.

Curious what others think?
Parent - By RSeanOConnell (**) Date 2019-12-25 16:33
I recently changed to 40 based on a reply in a post.  I was at 30 for my Opening projects and 20 for Middlegame positions.
Parent - - By pawnslinger (****) Date 2019-12-25 09:59
When performing the analysis, what are the counts that show up in the "Project Status" pane?  A screen shot of it might help.  A screen shot of "IDeA Project Properties" also may help.  Is there a chance that you have more than 1 project using the same tree file?  I have done that, and it is a tree eater.  I don't have any other ideas at the moment.  But be careful with your backups, you may want to save them in some place AQ doesn't use, so they don't age out while you are trying to figure this out.  You can surely restore the backup by just copying the relevant files, but until you find the cause, it might just happen again.  This probably doesn't apply to you, but the last time this sort of thing happened to me, my Aquarium.dir had the wrong information in it (I had forgotten to fix it after messing around).
Parent - - By RSeanOConnell (**) Date 2019-12-25 16:38
The backups are on an external drive.  Separate from my Aquarium directory.  My D: drive is for Aquarium data, pgn files, etc.  I simply copy the entire D: drive when I back up.

How do I enter a screen shot?  I am used to Ctrl/Printscreen and then Control V.  Apparently it's not that simple.  :confused:
Parent - - By pawnslinger (****) Date 2019-12-25 17:35
Okay, Aquarium provides per project backups... if you search around in the Aquarium data directory for the word "backup" you should find quite a lot.  However, when you find them, you will note that they are aged, and will automatically be deleted after awhile.  So for example,  you can restore to 3 days ago.  But it is a manual process, you have locate the backups and copy the relevant files yourself.

The forum allows you to upload jpg files, you can use Ctrl-Printscreen, but then use a program like Photoshop or Gimp (its free) to create an image from the Clipboard.  I do it all the time.  Once you have an image file, you can attach it or embed it in a message in the forum.  And I always crop the image in Gimp, to just include the salient parts.
Parent - - By RSeanOConnell (**) Date 2019-12-25 17:54
Hmm.  I searched the Aquarium directory and entire D drive.  No backed up files found.
Parent - - By mattchess (**) Date 2019-12-25 18:41
DATA--->ATREES--->BACKUP
Parent - - By RSeanOConnell (**) Date 2019-12-25 19:55
BACKUP folder does not exist.  Is it possible this was not available in the 2014 version?
Parent - By pawnslinger (****) Date 2019-12-25 20:07
Anything is possible.  I don't recall when the backup folder was first introduced.   I am using AQ2017 and I don't think it was the first with the backup folder.  I do remember that in some earlier versions of AQ I would lose trees often, and got in the habit of doing my own backups... but I have not had to do that for a long time now.

Maybe a good reason to upgrade.  Fewer bugs and automatic backup creation.  For me, going to AQ2017 was a big difference in the level of bugs I ran into... I still have problems once in awhile, but nothing that requires a restore from backup in a LONG time.
Parent - - By RSeanOConnell (**) Date 2019-12-26 21:00 Edited 2019-12-26 21:03
I downloaded Gimp, took a screen shot and have it open in Gimp.  Don't kow how to save as a jpg though. 

I was able to upload it in another post but don't think .XCF is the correct format?
Parent - - By pawnslinger (****) Date 2019-12-27 00:03
Under File, there is the export option... you can choose the file type by specifying the file extension... jpg for jpeg.
Parent - By RSeanOConnell (**) Date 2019-12-27 02:10
Doh.  That was easy enough.  Screen shots below.
Parent - - By RSeanOConnell (**) Date 2019-12-26 19:26 Edited 2019-12-26 20:42
I upgraded to 2020.  There was not a "Backup" folder at first but appeared after I ran Idea for a few minutes.  I am assuming that feature was not in 2014.  That by itself was a good reason to upgrade.

As far as the Idea tree problem I think I am planning on starting fresh with the 2020 version and a more powerful machine.  And the 2014 tree files are not compatible with 2020.  I have most of the positions in databases or the 2014 projects.

Edit:  Grrr.  I started fresh with 2020.  A new project.  I stopped Idea to see if the Tree problem has been fixed.  I have been sitting here for quite awhile waiting.  It still seems to be in an endless loop.
Parent - - By Ghengis-Kann (***) Date 2019-12-27 00:36
"Somehow the box "Master Tree" in the Idea setup got checked.  I don't use a Master Tree.  Just the analysis tree which is the same as the project name. "

You have to define a Master Tree whether you use it or not.

I always create one in called (project name)_MasterTree.aqt then never look at it or do anything with it again.

I think the problems you are having may be related to not having a master tree.
Parent - - By RSeanOConnell (**) Date 2019-12-27 02:06
That seems odd.  I have had the Master tree field blank for years and have not had any problems until recently.  I did, however, define a Master Tree before starting the new Idea project.

I started the project before taking my daughter to the movies.  Came back and it actually has some positions now.  I stopped Idea and now it seems to be in that endless loop.  Will let it go for awhile and see what happens. 

Wondering if I have things set up right.  Everything had been working with the setup I have been using.
Parent - - By pawnslinger (****) Date 2019-12-27 04:46 Edited 2019-12-27 05:25
Attached please find screen shots of the project I am currently working on.  I have removed all the extra engine trees from my configuration, so it is a much simpler tree.  Please note I never use a Master tree either.  From the description of your problem, and the screen shots you uploaded... and what I've been told by others, your tree is hosed.  I would start over... with a complete new tree (and unless you know exactly what you are doing, DO NOT use the same tree name again... if you do, this will likely cross back to the hosed tree, and you don't want that).  When I find myself in this situation, I call the new tree like this: "TreeName02", and of course you substitute your your tree name for "TreeName".

Here are my screen shots:
Parent - - By RSeanOConnell (**) Date 2019-12-27 08:22
Thanks.  Can you send a screenshot of your tree configuration?

I understand what you are saying but I started a brand new project in AQ 2020.  The name may be the same but different AQ version, different folder, etc.  I left about 4 hours ago.  The project had been stopping and minimaxing for about a hour when I left.  When I returned it was still in the loop.  So, I forcefully shut everything down.  Restarted and the tree is now fine.  Screenshot below.  Actually have some positions, etc.  I am going to start it up again now before I go to bed and let Idea run all night.
Parent - - By pawnslinger (****) Date 2019-12-27 11:43
I did not include it before, because it is totally irrelevant... but to show you... here it is.  I do not know why I left the H5 and Master Tree columns in it.  I think I could take them out with no change.
Parent - - By Ghengis-Kann (***) Date 2019-12-27 14:44
Perpetual minimax occurs when there is a position disconnected from the tree in a way that can't be traced back.

Right click on the tree window and make sure "add moves to main tree" is set to Always.
Otherwise it is possible to manually add positions in the notation that do not get added to the tree.
If you then add a node it can be disconnected.

Also start every project at the initial position and make sure you have every position from there to the actual starting position of your project in the tree.

Be careful when adding positions from the database because that is another way you can add positions that are disconnected from the tree.
Parent - By RSeanOConnell (**) Date 2019-12-27 16:09 Edited 2019-12-27 16:28
Just checked.  It was set to "None."  I changed to "Always."  Hopefully that fixes it.  Weird seeing the tree just flash and continually update never finishing the minimax.  How do I know if a move has not been added to the tree?
Parent - - By RSeanOConnell (**) Date 2019-12-27 16:12
Pawnslinger - The tree configuration may be irrelevant to what is happening with my projects but I was curious about *idea.  That is there by default when we create a tree but I changed the field to point at the actual project trees.  Should I have left it as *idea?  If all of the tree configurations have *idea does that mean they are all writing to the same tree?  Please explain what *idea means/represents.

Here is what mine looks like.
Parent - By Ghengis-Kann (***) Date 2019-12-27 17:39
Moves that are part of the main tree have bold font in the tree window and those that are not have standard non-bold font.

It really should default to always because the expected behavior is that a move you manually enter would be added to the tree.
Clicking the "all positions" 4 red thumbtacks button will add tasks for anything in the notation window that is not in the tree, which also adds them if they are not part of it already.
Parent - By pawnslinger (****) Date 2019-12-27 21:20
I do not know.  I can only guess.  Since I have not changed it, I am assuming that all my IDeA trees have the same configuration.  But I still have individual trees.  Since you have changed it, perhaps that means that you have created a specific tree type.  How that would work, I do not know.  Maybe someone else, who has used this feature can explain in more accurate detail.
Parent - - By pawnslinger (****) Date 2019-12-27 21:25
I believe that the *Idea is a "tree type".  All trees of a certain type have the configuration you have set for that type.  So individual trees would not normally have a particular configuration.  At least that is the way I "read" it.
Parent - By Ghengis-Kann (***) Date 2019-12-27 21:48
At this point I recommend you do a clean install in a new folder and start analyzing the initial position of the default Idea project with Rybka or Weak Delphi.

See if the problem still occurs. If it does then it is a problem with your computer, and if not then it is a problem with the way you are using Aquarium.
If it works fine with everything as default then take one little step at a time until it either does what you want or you identify the point where things go wrong.
Parent - - By dickie (**) Date 2019-12-28 11:48 Upvotes 1
RSOC

This thread has become a little confusing, but here is another contribiution.

*idea is a generic term that simply points to the current project being viewed, whether it be Hippo or any other. It is there by default and there is no need to change it. Similarly there is no need to create a separate configuration for Hippo. The default IDeA configuration applies to any tree and will show the moves relevant to each viewed project, whether it be Hippo or Modern – Austrian Attack, etc.

There is no need to set a master tree. The term “master” is misleading. It is simply any other tree from your ATrees files that can be attached as a second tree to any project. It can be useful for transferring data between trees or comparing one tree with another in the configuration window. It can be safely ignored if it has no use for you.

If a project is missing, check for the presence of the project.xml file in the IDeA\Projects folder. If found, open it in a text editor and check that the project is properly described in the first two or three lines.

Whether “add moves to main tree” is set to None or Always is a matter of personal choice. I cannot recall disconnected positions in my trees causing minimax problems.

If a project is continuously minimaxing, close and reopen Aquarium and then minimax using the project “Manage/Minimax Tree Now” drop-down menu. That sometimes works for me. There is also the Tree/Verify tab to try. Otherwise I agree with pawnslinger that your tree has probably become corrupted. If you have trouble finding a working backup, you can always recreate your tree from the project.epd file found in the IDeA\Results folder. This file contains the result of every completed task. It is interesting to read in a text editor because it shows for each task the time used, depth achieved, final evaluation and pv. Create a new tree and then use Manage/Add Results to open the relevant project.epd file. Aquarium will take a little time, depending on the file size, to build the tree. Then minimax to complete. Your original tree should be restored.

.aqt tree files were used in Aq2014 so they will be compatible with Aq2020 and can be transferred without need for conversion. Older .hsh files can also be converted to .aqt files if necessary.
Parent - - By RSeanOConnell (**) Date 2019-12-28 22:27
Thank you.

I guess I understand *idea when you are in Idea looking at a project but what about when you want to see the results of a tree from within a database?  I am in a database now and selected the IDeA tree configuration but no results and pointing at the wrong tree "(IDeA\My Positions.aqt" when it should be "IDeA\Hippo.aqt" which does have positions when I am in IDeA.

I did take care of the missing project problem.  I backed up all of my AQ2014 data.  I thought I had to manually copy the .aqt files to AQ2020.  I used the Import Project(s) option.  They imported just fine.

As for the minimaxing I uninstalled and reinstalled AQ2020.  Created a brand new project.  Still having doing it.  I then imported my old projects.  Still doing it.  Minimaxed as you suggested.  Still doing it.  When I shut down and reopen AQ the results are in the tree.  But, multiple instances of the .aqt file have been saved.  Screenprint below.  There were 157 copies when I shut down AQ.  I have emailed ChessOk for help.
Parent - By pawnslinger (****) Date 2019-12-29 02:16
I do not know what is causing this problem.  I would follow the advice that Ghengis gave you.  Basically start a new tree very simply.  Use all defaults, change as little as possible.  Then test the tree.  If it works okay, make a modification.  Test.  If it works, rinse and repeat.  In this way, you can try your mods one at a time and find which one is causing the problem.  Frankly, I don't use the database features at all, and I have never seen anything like the problem you are having.
Parent - - By dickie (**) Date 2019-12-29 10:53

> I am in a database now and selected the IDeA tree configuration but no results and pointing at the wrong tree "(IDeA\My Positions.aqt" when it should be "IDeA\Hippo.aqt" which does have positions when I am in IDeA.


There will be an error somewhere in your configuration, possibly in the project xml file. If you look in IDeA\Projects you will probably find a lot of Test.xml files now, but maybe also a couple of Hippo.xml files that might cause some ambiguity.

I notice in another thread that you have inadvertently been allocating more cores/threads than available on your pc. Have you also as, a consequence, been allocating more than your available memory? It can have unpredictable effects, including never ending minimax.

Do you have a D:\ partition? I think, in the past, we have been advised not to install Aquarium on the C:\ drive, though I have no idea why. The multiple Test.acq files are a mystery, but there must be something wrong with your setup.
Parent - - By RSeanOConnell (**) Date 2019-12-30 02:12
Interesting.   On my old laptop I do a have a D: drive.  Not on the new one.   The endless minimax is happening on both.   With new installs, imported projects, and new projects it keeps happening.   I have emailed ChessOk.  They asked for screenprints and the Aquarium.elf file so the programmers can look at it.  The .elf file does not exist on my setup.   I ultimately searched the entire hard drive.

With that said I will reduce the Ram used per engine instance.   I have been maxing it out.
Parent - - By pawnslinger (****) Date 2019-12-30 18:45
Again, I recommend going back to a vanilla setup -- maxing out ram is not vanilla.  I think vanilla is 32mb cache per engine.  You have something (perhaps many somethings, very wrong in your setup...) and maxing out ram IS wrong.
Parent - By RSeanOConnell (**) Date 2020-01-03 18:49 Edited 2020-01-03 18:53
I tried that.  Fresh install of AQ2020.  Ran a Test project in the default project.  Still happens.  ChessOk is looking into it.  For the time being I am shutting down AQ and reopen it with the results showing in the tree.  This is working ok but I now have 259 copies of this project tree.
Up Topic Rybka Support & Discussion / Aquarium / Idea Project Problems

Powered by mwForum 2.27.4 © 1999-2012 Markus Wichitill