Not logged inRybka Chess Community Forum
Up Topic Rybka Support & Discussion / Aquarium / RTHomeServer Help
- By pawnslinger (****) Date 2019-02-07 22:31
Okay, I am a bit lost.  I downloaded the RTHomeServer.rar file, but it does not contain either RTHomeServer.exe or RTHomeServer.ini.  It has RTSingleServer??  Both ini and exe.  I did also download someone's RTHomeServer.ini (posted in this forum) and it looks a lot more complicated than I thought it would.  Hard to even find the [main] section (it was way at the bottom).

I am considering buying some used servers, but before I lay out a lot of cash, I was going to try and and see if I could get this working.  Any guidance would be appreciated.
- By pawnslinger (****) Date 2019-02-08 00:07
Alright, I think I got that cleared up... there is no RTHomeServer.exe (I went to ChessOk and re-read the doc there and it is becoming a little clearer).

So anyhow, I have setup Stockfish on my wife's computer using port 7788 with RTSingleServer and it looks okay, but I cannot connect to it from my computer.  We are both on the same local network, both using Windows 10, both have the firewall opened for the programs to talk on the "Private" network thru Windows firewall.  I double checked the ip address used by my wife's computer.  But I can't connect.  Do I need to do something to open the port?  I didn't see how to do that when I opened the firewall.

The ChessOk doc said that the user/password weren't used... do I have to have those filled in??  I tried "user" and "user" and "MyUser" and "MyPassword".  Neither seemed to work.  Do I need to somehow login to her computer first?
- - By pawnslinger (****) Date 2019-02-08 01:54
Okay, my son helped me and it is now working.  It was due to some arcane setting in the Windows Defender firewall.  I don't know why, but my wife's computer had considered our local wifi to be a public network, so I had not correctly set the firewall settings for it.  Now it is working great!!
Parent - - By pawnslinger (****) Date 2019-02-10 18:49
Is there anyway to run RTHomeServer on Linux?  I just finished watching a YouTube video about Steam games on Linux and I am envious.

https://www.youtube.com/watch?v=J4U93SBuK68
Parent - By CumnorChessClub (***) Date 2019-02-10 23:00
Parent - - By Ghengis-Kann (***) Date 2019-02-12 00:44
Hi Pawnslinger.

That Steam Linux thing is what I was trying to describe to you in another thread.
Thinking maybe Aquarium might work with that distro.

I am going to make a foray into linux myself soon.
Brother in law suggested Ubuntu as easy to get started with.

Just to make sure, you are running RTHomeServer406 right?
There was an earlier version called just RTHomeServer.
Parent - By pawnslinger (****) Date 2019-02-12 17:28
Hi Ghengis:

I am running RTSingleServer dated Feb 2009.  Old, old, old stuff.  But it does work.  I purchased an old server off of eBay and it is arriving Friday.  I cannot believe how cheap those things have become.  Of course, it is running really old Xeons, but from what I hear they are still pretty good.  I am going to have to mod the heck out of the thing, to do what I want, but from the things I have seen others do, it should be worth the effort.  It comes pre-loaded with Win10 Pro, and I am okay with that, but I sure have the itch to run Linux on it.

Does anyone know if the source code for RTSingleServer has been released into the wild??  If it has been, I would be happy to take a stab at conversion.  I am an old C programmer and have some background with Unix... and therefore, by extension Linux (which is based on Unix).
Parent - - By pawnslinger (****) Date 2019-02-12 20:18
I googled RTHomeServer406 and can't find a download link for it anywhere.  In fact, I can only find it mentioned at all in this forum.

How can I download it??
Parent - - By CumnorChessClub (***) Date 2019-02-12 22:25
I think the links on forum  for RTH 4.06 no longer work, you can download it from my back-up here https://app.box.com/s/mvh8hlbsk47nb3tvgle5qk9tqkv273gs
Parent - - By pawnslinger (****) Date 2019-02-12 23:46
I tried that link, but I couldn't download the rar.  Said something strange about unsupported file type.  Never seen that error before, figure it must be something wrong with my browser (Firefox).  So I couldn't get it.  Is there someway that it could be uploaded here??
Parent - - By CumnorChessClub (***) Date 2019-02-13 09:01
Top right of the site page is download button take no notice of the notice in the middle of the page, thats just a display error.
Parent - - By pawnslinger (****) Date 2019-02-13 09:28
Okay, thanks!!  I got it.

Does anyone know what the differences are between the old version and 406??  The ini file sure is A LOT bigger and more complicated.  I notice sections called 1_engine and others like that... anyone know what all that is about??

Can this version control multiple engines??

In the old ini all I had to do was change the port number and the engine path.  Maybe the hash size and the max_cpus (or something like that).  Is that all I need worry about in this version too?

Thanks for the help.
Parent - By Ghengis-Kann (***) Date 2019-02-13 17:09
I change the port, engine, and location where the log files are stored.
You will want to periodically delete the log files.

My set up is a separate folder for each engine I will run in Aquarium.
There is no need to re-name the engine in the folder, you can name them individually when they are added to Aquarium.
It s possible to do this over the internet but better to use your local area network.

Not sure how to do it in Linux, but in Windows you run cmd to open a command prompt and type ipconfig/all.
The Physical Address is what you want to enter into the add remote engine box in Aquarium along with the port that is specified in the config file.
It will be something like 192.168.001.XX or 192.168.254.XX depending on the manufacturer of your router, where XX is the designation of the remote computer.
For example, I have 2 different remote computers with addresses 192.168.254.22 and 192.168.254.13. That tells Aquarium where the remote computer is, and each remote engine will communicate on a unique port.

The hash size and such that you enter into the config file seems to be over ridden by the engine settings in Aquarium, so don't bother.

The only other thing I recall changing is the location of the RTHomeServer406 window on the screen.
There are X and Y coordinates you can enter into the config file for this, as well as a designation for whether it starts minimized.
I have had issues with copying config files from a computer to a different computer that did not have the same screen resolution causing the RTHS window to be drawn off screen.
- - By pawnslinger (****) Date 2019-02-16 02:54 Edited 2019-02-16 03:29
Thanks for everyone's help! 

Today I took delivery of my Dell dual cpu Xeon server.  So far I have got it setup, Windows updates installed and 5 innstances of Stockfish running.  It has the capacity for many more, but I am starting slow, to see how it goes.

So far, my biggest headache is Windows Update... I had to learn how to use the policy editor to disable Windows Updates.  I can't have it rebooting the computer to do an update in the middle of analysis.  Fun, fun, fun!!
Parent - By pawnslinger (****) Date 2019-02-17 23:58
The Xeon cpu's I am using are the X5675 version.  A 6-core variant with hyper-threading.  My main desktop uses an AMD Ryzen cpu, the 1700x.  Both systems are running at stock clock speed (I am not a big over-clocker), which is working out to about the same frequency.

Now the surprising thing is that the engines on the Xeon are running about 25% faster.  I am not sure why, but I think it must be due to the large L3 cache on the Xeon chips, because the Xeons are running on pretty slow DDR3 memory.  I guess LGA 1366 is not dead yet!!

Oh, yeah, the Xeons are running triple channel memory, which helps too, I am sure.  My AMD system is using dual channel memory.  The Xeon memory is clocked at stock 1333 mhz, and the DDR4 on the AMD system is running at 2400 mhz.  Both the systems are turbo-ing routinely up to around 3.4 ghz.  Makes me wonder why I didn't just go with a Xeon system instead of AMD for my personal computer.

One minus for the Xeon based system, it is running a good 12 C warmer than the AMD system, and the energy consumption, per my Kill-A-Watt meter is approximately twice as high for the Xeon system... 275 watts vs 140 watts.  So my electric bills will be higher.
Parent - - By pawnslinger (****) Date 2019-02-18 00:58
I am using TeamViewer for remote control of my Chess server.  It is working pretty smoothly.  I wonder how other people are doing it?  Is anyone running their server headless?  I have been considering that... I would be interested to hear how others have done it.
Parent - By chesspjn (**) Date 2019-02-18 09:34
If your server is using windows 10 pro you can use (I have a Swedish version but would translate to) Microsoft remote desk.
I have 3 computers, 2 desktops and one laptop, I am monitoring the desktops from the laptop using TightVNC, working well, can even log in remotely with it. TeamViewer is OK when I am out and want to check, but it takes too much memory on the desktops computers and they make a reboot.
Up Topic Rybka Support & Discussion / Aquarium / RTHomeServer Help

Powered by mwForum 2.27.4 © 1999-2012 Markus Wichitill