Not logged inRybka Chess Community Forum
Up Topic Rybka Support & Discussion / Aquarium / Problem linking IA to IDeA with Stockfish 10.
- - By Kappatoo (*****) [us] Date 2018-12-10 23:46
I have a strange problem with Stockfish 10 in Aquarium. I just made it my standard engine for IA, and in the Engines Setup, I clicked the box 'Add moves and evaluations to IDeA tree'. But it won't do it. It will only add tasks to the IDeA queue, but not add evaluations.
I never had this problem with previous versions of Stockfish, and as far as I can tell, I used the exact same settings. It acts as if it's set to 'Send positions from analysis line into IDeA queue.' Any ideas what's going on?
Parent - - By ChiefPushesWood (**) [us] Date 2018-12-11 11:52
Hard to say whats going on without more information. The immediate question that comes to mind is: Do you have the tick box checked 'Insert Infinite Analysis from linked games'? This box is in the IDeA project properties box. Then, of course, make sure the Min Time and Min Depth are set to allow this to happen.

I'm running SF10 as one of my engines without issues - for the record.

CPW
Parent - By ChiefPushesWood (**) [us] Date 2018-12-11 12:13
I had a few minutes so I ran a test on a new, blank IDEA project. I can confirm, on my end at least, that the tree is being populated with the IA line and eval.

Due to a display bug, sometimes I have to 'refresh' the screen by stepping back a move and then forward to see the information populate in the tree. (make sure you have the position locked if you don't want to lose any IA work)

Also, I'm not CERTAIN that the Insert infinite analysis from linked games actually makes a difference in this scenario. I just always have that on.

I don't really do this as a matter of course for my own analysis. I would be worried about crazy lines (horizon effect??) getting into my tree further down the variation. To be fair, I could be completely off-base and wrong about that concern.

CPW
Parent - By Kappatoo (*****) [us] Date 2018-12-11 15:23
Thanks for the reply! Yes, I have this box ticked, and it's set to reasonable time and depth. (Again, with the same settings, I never had an issue before.)
Parent - By Kappatoo (*****) [us] Date 2018-12-11 15:35
I'm now running a slightly older Stockfish version with the exact same settings in Aquarium, and it sends evaluations and moves to the tree without any issues.
Parent - - By pawnslinger (****) [us] Date 2018-12-11 15:59
Which version of Aquarium are you using?

I am running Aquarium 2017, so perhaps you have a different version.  I don't know??

When asking for help, the more info you can give about your setup the more we are likely to be of help.

In my case, when I get a new version of Stockfish, 10 or any other, I do something that probably not everyone does... I do NOT create a new engine entry for it.  I simply go into the old Stockfish entry and update the path to point to the new EXE.  If ever Stockfish changes their parameters, I know this could be a dangerous practice, but it does insure continuity of performance from Aquarium, because I am guaranteed to have all Aquarium parameters set as before with the old engine.

One side effect of my method, Aquarium still thinks it is running Stockfish 8 -- but it isn't, it is running 10, or whichever dev version that I have loaded currently.  I can't tell the difference unless I go look at the engine path in the Aquarium setup.  For some this could be confusing, I guess.  But it works for me.

As you can see, I have been following this method since Stockfish 8 with no ill effects.  Sometimes when updating the path, I do make a typo, but Aquarium warns me of the error and it is easily corrected (it warns me that it can't find the EXE, because of my fat fingers).
Parent - - By Kappatoo (*****) [us] Date 2018-12-11 16:33
I have Aquarium 2018.
Does that mean you don't even change the engine name? I might try this. But I'm still confused why I suddenly get this problem. I have added new engines many many times without ever running into a problem like this.
Parent - - By pawnslinger (****) [us] Date 2018-12-11 17:19
I do not know why you are having this problem... but NO, I do not change the engine name.  I change ONLY the path to the EXE.  I was very specific in what I do.  Just the path to the EXE, that is all.

When you look at the name of the engine on my system, it says Stockfish 8, all the time.  No matter which engine is running (if it is Stockfish... I do use other engines also, and they all have their own names).
Parent - By ChiefPushesWood (**) [us] Date 2018-12-11 17:53
I do something very similar with my setup. FYI, Kappattoo, I'm running Aquarium 2018 as well.

In my setup, I've a very specific layout for my engines. Each new iteration of SF gets renamed to the existing labeling. This does the same thing that Pawnslinger's setup does... It ensures that nothing ever changes with the engine setup dialogue inside of Aquarium. I just find Aquarium more stable the least amount of fiddling I do inside of it. Further, I believe my system addresses the issue of SF naming/renaming issues. It doesn't matter what the devs name it since it gets changed by me when placed in my engine folder anyhow.

IE. (inside my SF folder)
Stockfish_Latest
Stockfish_Latestx
Stockfish_Latestxx
Stockfish_Latestxxx
etc.
Aquarium points to the folder and is looking for 'Stockfish_Latest'
The entries with x's are older versions. This also allows me a quick fallback if there are any issues with the latest version.

To give credit where it is due, I got this idea directly from Pawnslinger. I only tweaked it to my own.

CPW
Parent - - By Kappatoo (*****) [us] Date 2018-12-11 18:52
Okay, I now did what you do, redirecting the exe path from the SF version I used previously to SF 10. Now it's working fine. I still have no idea what could be causing this.
But thanks for the suggestion!
Parent - By ChiefPushesWood (**) [us] Date 2018-12-11 20:14
Glad you got it working!! Enjoy

CPW
Parent - - By ChiefPushesWood (**) [us] Date 2018-12-11 17:59
Which version of SF are you using?

CPW
Parent - - By Kappatoo (*****) [us] Date 2018-12-11 18:49
SF 10 is the one that's acting weirdly. The previous one that's working fine is some post-SF 9 development version.
Parent - - By ChiefPushesWood (**) [us] Date 2018-12-11 19:40
Yeah... but which one? The main release? Dev version of some kind?

The more specific you are, the more likely someone will be able to drill down and figure out what is going on.

CPW
Parent - - By Kappatoo (*****) [us] Date 2018-12-12 02:22
Yes, a development version between SF 9 and 10. I don't have my computer with me, so can't check which version number exactly. In any case, it worked without problems - just like all other engines I had used previously.
Also, the only thing I change in the settings is the number of threads used (since it's 1 by default in SF).
Parent - By pawnslinger (****) [us] Date 2018-12-12 16:34
I do not know if this means anything or not... but I always use only 1 core and PV for my IA engines.  I have tried otherwise, and it has not ended well for me.

Now I use different engines in the Sandbox (Stockfish, but under a different name) and there I use many cores and MV.  I use as many cores and variations as seem possible and appropriate under the game circumstances (and my computer will support).

But IA... different story, I use strictly single core and PV there.
Parent - - By pawnslinger (****) [us] Date 2018-12-11 18:58
Hi Chief:

Because of other problems I have had, I do not send the evaluations to the tree.  The primary problem that I have run into is the 299.xx eval.  Recent versions of SF are not as bad as they used to be, but I still see it come up in the Sandbox from time to time.  So I don't trust it yet.  I am using a mix of SF 10 and a dev version from a month or two ago (pre 10 release... it works pretty good I think, so I hate to give it up).

Overall, I am using 12 different engines at the moment.  Latest additions are: SF 10, Komodo 9.02 and Xiphos-0.4.  Finally retired Komodo 6.

I am fond of old and 2nd tier engines (as you can see).  They add variety, the spice of life.
Parent - - By ChiefPushesWood (**) [us] Date 2018-12-11 19:39

>Because of other problems I have had, I do not send the evaluations to the tree.


No, neither do I. Was only trying all this on a dummy game to try to help him.

I'm still too anal to trust anything. I try to control everything (within reason)

I limit my game load so I can do what is necessary to feel comfortable before sending a move.

CPW
Parent - By pawnslinger (****) [us] Date 2018-12-11 20:31
Hi Chief:

Yes, I try to limit my game load as well...  but you know what the bard said... something like this: The best laid schemes o' Mice an' Men, Gang aft agley.  I am sure I butchered that quotation.  In modern English, the best laid plans often go awry.

Last year is a prime example for me... I had it all planned out, then I got into several semi-finals and 1 final (by surprise... I did not think I would make it).  Well, that threw my whole game load into a mess.  Now I am hoping that my plans for the coming year go "as planned"... <grin>
Parent - By ChiefPushesWood (**) [us] Date 2018-12-11 20:10

>They add variety, the spice of life.


Indeed. When I'm in the mood for this, I have Komodo 12 MCTS give me some lines/ideas. Lot of fun stuff in that for sure.

CPW
Up Topic Rybka Support & Discussion / Aquarium / Problem linking IA to IDeA with Stockfish 10.

Powered by mwForum 2.27.4 © 1999-2012 Markus Wichitill