Not logged inRybka Chess Community Forum
Up Topic Rybka Support & Discussion / Aquarium / Minimaxing issue
- - By cma6 (****) Date 2018-11-15 16:52
In IDeA, I suddenly have a problem where minimaxing, does not end, whether I invoke it during analysis from from the Manage menu or when I "End IDeA". In the latter case, I have to use Abort. In both cases, the status message at the bottom of the screen is "IDeA tree: minimaxing."
The only way to close Aquarium is via Windows Task Manager.
    This is happening with all projects, which have been checked with Tree/Verify.
Parent - - By pawnslinger (****) [us] Date 2018-11-15 17:19
I have had this problem, but not recently.  I was told at the time that the tree involved was corrupted, but it passed the tree/verify without problem.  Just as you describe.  I believe it turned out to be the xml file that was corrupt (I found out by trial and error, I started deleting files until it began to work again).  I could not afford to lose the tree itself, and it was NOT corrupt, despite what people in the know told me.  I still have that tree in operation today... not corrupt.

I cannot imagine why ALL of your trees are affected.  I would be tempted to backup my data and reinstall a fresh copy of Aquarium.  I have lots of trees and thankfully have not had this issue for a long time.

Please know that deleting the xml file, as I did, is somewhat difficult to recover from.  I had to create a new project by the same name and copy the saved tree over the top of the new empty tree.  It was a last resort for me, and could easily have resulted in a completely fubar tree.  So be careful, I do not recommend doing this unless you cannot fix in another way.

Nowadays, I backup (over several rotations) all my data files.  Best to have backups... complete backups.
Parent - - By cma6 (****) Date 2018-11-15 17:28
Pawnslinger,
Thanks for the prompt and detailed response. It may come to doing what you suggested some day. Aquarium is such a complicated program which does so much that it is very difficult to diagnose and repair symptomatic issues.

In this case, the problem was caused by my adding 3 iterations of Komodo 12.2.1 as IDeA engines. Komodo 12.2.1. works fine in i.a., but apparently IDeA does not like to use it as and IDeA engine. I checked my Komodo 12.2.1 IDeA engine and its parameters but don't see anything wrong there. So I will alert the Komodo team, though they will likely suggest "Check with Chess OK!"
Parent - By ANUAR71 (**) [my] Date 2018-11-16 07:08
I agree with this . I have not used the Komodo for a long time in aq
Parent - - By cma6 (****) Date 2018-11-15 17:45
Pawnslinger,
  Do you remember which xml file(s) you deleted; did they have the project names?
Parent - - By pawnslinger (****) [us] Date 2018-11-15 21:47
Yes.  They are named after the project.  I forget where they are located, I always use the Windows search function to find all files that contain the project name.  It is a fairly long list, as it includes all the backups, epd's, etc.  But I think that it will only find 1 xml file named after each project.

When I tried setting up multiples of the same engine (not Komodo though), I always have to create a separate installation of the engine, with a different name.  So I have folders like this:

Stockfish-i1, Stockfish-i2, etc.  The 'i' in this case stands for iteration.  Then I have to rename the exe files to match the iteration name, i.e. Stockfish-i1.exe, etc.

For some reason if I don't do this Aquarium gets mixed up (on my computer anyways).  I have never been able to get an engine with copy protection to work properly with multiples, so I don't use the newer Komodo's nor Houdini's.  I find their copy protection causes me too much trouble.  So I pretty much stick to free open source (or older) engines.
Parent - - By Ghengis-Kann (***) [us] Date 2018-11-19 17:42
I have over 50 separate installs of Komodo 12.1.1 spread over 4 different computers and have run 40 of them simultaneously, with 30 of those on a single computer.
I use separate folders with complete RTHomeServer406 copies for each engine and give each a distinct name and port in Aquarium.

This has never caused any copy protection issues.
Parent - - By pawnslinger (****) [us] Date 2018-11-20 04:32
Maybe the trouble I ran into has been fixed, or maybe it was just pilot error.  I gave up on both Komodo and Houdini (due to the problems) several versions ago.  And I mean quite a long time ago.  So things could have changed... I just don't have the time to figure this stuff out.... it either works, or I move on.  So it definitely could have been my error (pilot error).  I just don't have time to deal with the issues.

I had a registered copy of both Komodo and Houdini on an old Intel processor, when I upgraded to AMD, the programs started failing, completely, not just the multiple copy problem.  So I lost all interest.  Even though the multiple copy thing was a problem in Aquarium, I had been able to use them as kibitzers in Chessbase.  But after the upgrade, no go there either.  So I just threw in the towel.

And, of course, it just could be my bias showing... I have never liked copy-protected software.  When I upgraded my system, the same problems happened not just with my copies of Komodo and Houdini but also Photoshop and Excel... so now I am using open source replacements for those too... Gimp and Gnumeric (they work a treat for me and no copy-protection to bother with).  Some folks might not be able to change, but the open source programs do what I need.  Ditto for the free open source chess engines.
Parent - - By dickie (**) [gb] Date 2018-11-20 12:13
Houdini has copy protection and, I agree, its use in Aquarium is sometimes problematic. I have used Komodo continuously in Aquarium from the very beginning and cannot recall ever having a problem with multiple instances, let alone with a single instance of the engine. Nor can I recall Komodo ever having copy protection. I do not have experience of AMD, but I am sure we would have heard long ago if there were a systemic Komodo/AMD issue. As you suggest, pilot error sounds a plausible explanation of your difficulties with Komodo. That's a shame because you are missing out on possibly the best analytical engine.
Parent - By ChiefPushesWood (**) [us] Date 2018-11-20 15:50
Hey Dickie,
Sent ya a PM, Pal.

CPW
Parent - - By pawnslinger (****) [us] Date 2018-11-20 21:28
I do not know the cause of my problems, but I assure you Komodo has copy-protection at this time.  Many programs do, even if they don't think they do, because the Windows install does not always translate when upgrading a system (not really an AMD issue, a Windows upgrade issue).  The program's install uses Windows registry, which does not always translate well to a new system after upgrade.  So it becomes "de facto" copy-protection.  Many program developers use it as a way to sell more copies of their software after new Windows versions are released.  I am unsure how many copies of Photoshop I have had to purchase because of this issue.  So I am now allergic to software that I have to pay for... that has such an install procedure.

On the other hand, Stockfish just works... point to the folder where it is and voila!  It runs.

The same is true of Aquarium... just point to the folder that contains AQ and bingo!  It runs.  Nice.

If you move the AQ folder, you do need to adjust some of the AQ parameters, but nothing in the Windows registry.  Which makes the program VERY portable.  I like.
Parent - - By ChiefPushesWood (**) [us] Date 2018-11-20 22:25

>On the other hand, Stockfish just works... point to the folder where it is and voila!  It runs.


This has been my experience as well with Stockfish. But it has also been my experience with Komodo. I've had Komodo ever since v. 9 and have upgraded at every upgrade point (including the latest 12.1 to 12.2.2). I'm running multiple instances of Komodo in 6 different instances of Aquarium without any issues at all.

YMMV

CPW
Parent - - By pawnslinger (****) [us] Date 2018-11-20 23:09 Edited 2018-11-20 23:11
I am glad you are not having problems.

I wish I had not.  I actually am using Komodo, just not a current version.  I was using version 5 _and_ version 6, but I have since stopped using version 5 (due to unknown problems encountered about a week ago).  I am still using version 6, and it works well, no copy-protection issues with it.  I think there is a later version available that has no copy-protection... the last I looked I think version 9 had been released without protection (I could be wrong, just going from memory).  Anyhow, I replaced Komodo 5 with another new engine, Xiphos.  It is much faster than any other engine I have, but not quite as smart as Stockfish or others.

My latest experiment is with the development versions of Stockfish.  They seem good, but actually not quite as fast as version 9 (the latest release).  But faster is not always better, as the author of Rybka pointed out a few years ago.

Actually, I do use Houdini too, but again a version without copy-protection, version 1.5a.  I find it works quite well, just a bit on the slow side.
Parent - - By ChiefPushesWood (**) [us] Date 2018-11-21 02:29
'Slinger,
How are you using Xiphos? IA ideas or IDEA?

CPW
Parent - By pawnslinger (****) [us] Date 2018-11-21 04:05
So far just IA.  I only use Stockfish for IDeA evaluations.  I have only been using Xiphos for a short while... I don't think it would be good for IDeA evaluations, because it doesn't seem to support a full enough UCI interface.  AQ is pretty demanding on that score for the IDeA engine... not so much for IA.

Xiphos caught my eye when I saw the knps rate on TCEC.  Boy oh boy, it is fast.  But it needs some work, I think, on evaluations (but it is playing stronger than Komodo 5 it is replacing).
Parent - By pawnslinger (****) [us] Date 2018-11-22 20:14
Crawling slowly out of the dark ages am I.

My latest engine addition: Komodo 9.02 - free download from the Komodo Chess website... works pretty good.  Looks to be an excellent replacement for Komodo 5 that I grudgingly gave up on... :cool:
Parent - - By Ghengis-Kann (***) [us] Date 2018-11-20 17:15
Hi Pawnslinger.

Copy protection is definitely a PIA for any system change.
I once replaced a bad motherboard and Microsoft Office was dead on arrival because it said it was on a new computer and I had already used my 5 allowed installs.
Houdini did the same thing to me at the same time, since my 4 allowed installs were used up, so I have sworn never to give Houdart another dime of my money.
Houdini 5 also caused RTHomeServer406 to throw random memory access errors.

Definitely tempted by Linux, but sticking with WIn7 X64 Pro for as long as I can.
Fortunately AMD, Gigabyte, and Nvidia have all released Win7 drivers for the Threadripper 2990WX, Aourus Extreme MB, and GTX 1080 Ti video card, so 7 lives on for another major upgrade.
Parent - By dickie (**) [gb] Date 2018-11-20 18:05
If you write to Houdart he will give you extra installs. But I agree it's a bit of a nuisance.
- - By Viktor (**) [ru] Date 2018-11-20 06:48
In my experience working with an Aquarium in case of delay of minimax on one project, I wait for it to finish. Sometimes it is painfully long, within a few hours. But, as a rule, the minimax ends. At the same time, I run another project for analysis, so that the Aquarium does not stand idle.
Of course, the error with minimax, alarming problems with the tree. And it should be checked, possibly restored. Good to do project compression.
Usually such problems occur when using the Tree Generation Strategy, which creates a lot of tasks. And at some point the minimax starts when the analyzing tasks are not completed.
In this I see a way out until the manual way: a little work project with a lot of tasks created by the Strategy and I stop it and turn on the minimax itself through Management. Then run again. And if there are a lot of tasks, then I do it periodically until their completion.
I asked the programmers to make the Strategy possible to stop the analysis before the minimax launch. Then this problem would not arise. But this has not been done yet.
Parent - By CumnorChessClub (***) [gb] Date 2018-11-20 20:02
I suggest everyone should open resource monitor then start aquarium then in resource monitor under overview tab tick aquarium under cpu. Yo will see aquarium reading and writing to disk.

Once the have disappeared then start your project you will some reading and writing to disk again. after stopping the project wait for these read and writes are finished before doing anything else. After finishing with Aquarium and you closed it down there will be some reading and writing wait for these to finish before doing anything else.

Since doing this with Aquarium I have had no issues for the last 3 years.

Maybe this will help some maybe not.
Up Topic Rybka Support & Discussion / Aquarium / Minimaxing issue

Powered by mwForum 2.27.4 © 1999-2012 Markus Wichitill