Not logged inRybka Chess Community Forum
Up Topic Rybka Support & Discussion / Aquarium / Problems with the SQL type of database in Aquarium 2017
- - By dli [us] Date 2017-03-16 00:18
I've been using Aquarium 2014 32bit to create some databases with ibooks to record information.  The ibooks require use of SQL (*.dsn) type of database.  I'm having trouble getting SQL databases to work with my recently purchased Aquarium 2017 64bit.  This means I haven't been able to use my ibooks in Aquarium 2017 due to this issue.  As a simple test, I opened the elite2008 database that comes with Aquarium, marked all the games, and copied them to the clipboard.  I then created a new SQL type database accepting the defaults and pasted the games from the elite2008 into the new SQL database.  The first time I tried this, the dialog showing the progress of the paste completed normally, the first page of games displayed fine, and at that point my Aquarium 2017 was completely frozen.  I had to use TaskManager to kill it.  I have tried this a few time and can sometimes click on a game or two or scroll the display a little bit, but in a short while, Aquarium 2017 freezes.  I have had this happen copying as few as 25 games from the elite2008 database.  I have had Aquarium 2017 occasionally get into a state where it displays popups complaining about invalid pointer and other similar complaints before crashing out or freezing, but the typical result is Aquarium 2017 freezing.  When I was trying to get my ibooks to work, I also installed Aquarium 2017 32bit copied the ibooks and databases over and encountered the freezing issue as well.  I didn't investigate further with Aquarium 2017 32bit version.  I haven't had any problems like this with my Aquarium 2014 32bit.

Is this a known issue or is anyone else seeing this?  I haven't encountered any other issue, so I can keep my ibooks on Aquarium 2014 for now and use Aquarium 2017 for other work. It would be helpful to confirm if this issue is unique to my system.  I'm running Windows 10 Home 64bit on an Alienware 17 laptop.

Thanks,
Larry
Parent - By dli [us] Date 2017-03-16 11:49
Forgot to mention that the when frozen, Aquarium is using zero CPU. Also this is Aquarium 2017 64bit version 9.5.0(build 950).
Up Topic Rybka Support & Discussion / Aquarium / Problems with the SQL type of database in Aquarium 2017

Powered by mwForum 2.27.4 © 1999-2012 Markus Wichitill