Not logged inRybka Chess Community Forum
Up Topic Rybka Support & Discussion / Aquarium / Anyone else also experiencing a stalling IDeA ?
- - By Sciolto (***) Date 2014-12-28 13:40
Using the 64bit 804 build with a tree that is not exceptionally large (100.000 - 200.000 leave nodes) IDeA at some point stalls / stops after a few cycles. It gets stuck at the stage 'Search for alternatives' indefinitely with zero cpu activity. I know this stage can take a while but I monitored the cumulation of the analyzed tasks in the session and the cpu activity for at least an hour on several occasions. When I use the upper left button to stop IDeA and then again to start IDeA it seems to 'wake up' and starts generating tasks again.

I must say that I am more than a bit disappointed to find that after many years IDeA is still not a reliable tool for chess analysis. I did read on the forum that the Aquarium 2015 version made some progress and so I decided to give it another try. Obviously 'we' are not there yet. I have send the complete project and tree to a Convekta developer hoping he can reproduce and fix the bug.
Parent - By pawnslinger (****) Date 2014-12-28 17:39
I have started several threads here that have a similar theme to your own.  As of last night, I have officially fallen back to Version 7.0.2 Build 725 of Aquarium 2014.  Later builds of Aquarium 2014 that I could find exhibited similar problems to what we have found with Aquarium 2015.  For my own use, Build 725 has only 1 fault I can find, the "Alternative" tab does not work properly.  Otherwise, the program operates fairly well, and I have not run into many problems.  Perhaps there are problems with Build 725, but I do not realize what they are, or have not run into them.
Parent - - By Dadi Jonsson (Silver) Date 2014-12-28 23:58
I haven't run into any problems with IDeA in the 2015 version.

What kind of position were you analyzing? An endgame position?

Btw. Pawnslinger's issue is due to excessively large task queue.
Parent - By pawnslinger (****) Date 2014-12-29 06:01
One of my problems is caused by an excessively large task queue.

What about the problems related to the large .epd files?  Caused by the fact that I do a lot of analysis (an excessive amount of analysis, I suspect).  And how about the problem caused by the large infinite analysis tree?  Also caused, I suspect, by excessive amounts of analysis.

I guess everything I do is excessive, as far as Aq 2015 is concerned.  Currently running Aq 2014 again, no issues to report, except the "Alternative" function.  I will continue to support Aquarium and ChessOk with my business, but until some of the kinks are smoothed out... I just need a program that can handle a lot of analysis.
Parent - - By Sciolto (***) Date 2014-12-29 20:21 Edited 2014-12-29 20:36
Not an endgame no. A sideline of B33 after white's 16th move.
I tried to rule out the large queue cause by reverting to the default tree settings which doesn't allow a lot of tasks to be added per prolongation. It didn't make any difference though.

When I investigate the \Data\ATrees\IDeA folder I find a suspect subfolder named <treename>$1.ldb_data that has over 15.000 small files with the .sst extention. All named with six digits, like for example 046480.sst being the highest number. This is accompanied by a 046483.txt file which is empty (zero bytes) and a MANIFEST-046482 file of 700 KB and a few other small files. As an ICT professional I think it to be dubious to have so many small files in a folder after closing Aquarium regularly. If they are temporary then why don't they get cleaned up? Most Window users will be familiar with the performance issues of folders with that many files.
Parent - - By Dadi Jonsson (Silver) Date 2014-12-29 20:56 Upvotes 1
That's not normal. This tree is damaged. I recommend that you check your trees and rebuild those that have problems. Also make sure that your virus scanner skips the Aquarium data directory.

The easiest way to check the trees is to use Tree > Verify. If there are problems with a tree (it needs compression or has an error), you can "Recover selected trees". I'll explain in more detail if needed.
Parent - - By Sciolto (***) Date 2014-12-30 00:04
Thanks! I found and used the verify and recover options. I will finish some non-IDeA analysis first before restarting IDeA to see if my problem has been solved.
Parent - - By Dadi Jonsson (Silver) Date 2014-12-30 09:21
Good. Since this is the first time that you use verify/recover I would do a thorough check (maybe you already did):

1) Tree > Verify > All IDeA projects
2) Tree > Verify > Configurations

Orange means that the tree is split into more than 50 files. Red means an error. If you use engine specific IA trees you might want to check those too (probably using the "Folder" option in Tree > Verify).

3) In the Aquarium status bar, right-click the IA history field and select "Compress trees" from the menu.
Parent - - By Sciolto (***) Date 2015-01-03 09:23
I did 1) and 2) and nothing seemed to be broken. Restarted the project with the same result: IDeA stalls.
Looked for 3) Compress trees, but have not been able to find it anywhere.
Parent - - By Dadi Jonsson (Silver) Date 2015-01-03 09:39
It's in the status bar.
Parent - - By Sciolto (***) Date 2015-01-03 11:54
I compressed the trees successfully. IDeA is however still stalling. When I restart the project it completes exactly one cycle. Upon the next iteration of 'Search for alternatives' I see activity in the folder in the image below for about half an hour before it comes to a complete stop, also no longer showing cpu activity.
Parent - - By Dadi Jonsson (Silver) Date 2015-01-03 14:13
If you like, I can try to run the project on my setup to see what happens.
Parent - By Sciolto (***) Date 2015-01-03 16:27
Thanks!
I wrote you an email with two dropbox links.
Parent - By Waschbaer (**) Date 2015-01-01 17:16
On my system that problem occurs often and makes AQ to a nogo for me.

As long as that bug is not fixed i will stay away from this in other aspect interesting software
Up Topic Rybka Support & Discussion / Aquarium / Anyone else also experiencing a stalling IDeA ?

Powered by mwForum 2.27.4 © 1999-2012 Markus Wichitill