Not logged inRybka Chess Community Forum
Up Topic Rybka Support & Discussion / Rybka Support / Install help!
- - By Gasturbine [us] Date 2012-02-09 18:34
I just purchased Rybka 4, and am using the Fritz interface. I installed both the 960 w32 and the straight w32. It was running fine, I played some games, and even ran some engine torneys with the. I turned on my puter today, started Fritz and got this error message;

The program is locked up. I get this message even when trying to switch or inactivate engines. Ive restarted the puter a number of times, and tried to reload the IUC, but to no avail...the program is now dead in the water. Any advice/help on this one?

Parent - By Labyrinth (*****) [us] Date 2012-02-10 00:26
What do you get under the 'more information' thing?

Can you run it from the console?
- - By rocket (***) [se] Date 2012-02-10 00:58
Have you  restarted your entire computer:grin:these fritz gui meltdown go away usually that way.
Parent - - By Gasturbine [us] Date 2012-02-10 17:57
Yes, Ive restarted several times. This morning, I completely deleted everything, reloaded Fritz (working fine under the Fritz 10 engine), went to load the Rybka, and the same error.
Parent - - By Mark Mason (***) [gb] Date 2012-02-11 09:49

I have seen this in the past and sounds like your Rybka 4 engine file has become corrupt. You need to delete the engine and re-create it. Delete the EXE file and the Rybka engine files from one of these folders (use your own drive letter):
H:\Program Files (x86)\ChessBase\Engines
H:\Program Files (x86)\Common Files\ChessBase\Engines.uci

Also you need to delete the uci file  - depending on whtehr you are running Windows XP or Windows 7. For Windows XP: go to  "C:\Documents and Settings\UserName\Application Data\ChessBase"   (Replace C with whatever your main drive letter is and replace user name with the name you logon with).  Inside you will see one or both of these folders  -  "Engines.UCI"  or  "Engines".  Delete the .uci file for Rybka.

For Windows 7 the path is different.  Click on your user name which was previously My Documents in XP.  Then go to  "AppData/roaming/chessbase/Engines.UCI"  Go in there and delete .uci file for Rybka.

NOW - you need a fresh copy of the Rybka engine EXE file and to do a "create UCI engine" again from the Fritz GUI. If the EXE file that came with your Rybka 4 is corrupt you need one from somewhere else. Of course anyone could email you a copy of the EXE but I am guessing that would be classified as piracy (even though you are a paying customer) which I do not wish to propose,  so I assume you would need to contact the support for wherever you bought the software and ask for another copy of the engine.

Hope this helps.

Parent - - By Gasturbine [us] Date 2012-02-17 13:27
Cant get it to work on 3 different computers running the Fritz (10) GUI. Ive even did a complete un-install (every hint of "Chessbase" removed), and still does not work.

I bought the engine in a .RAR file, and have repeatedly unzipped it to confirm the file is "fresh", but still no luck.

I wonder if it is a interface problem. To open my GUI, I have to run Fritz Chessbase's "ChessbaseProgram10.exe"...I wonder if I would have better luck running it under Aquarium?

Is there some where I can get Aquarium?
Parent - By Mark Mason (***) [gb] Date 2012-02-18 08:44

I run Rybka 4 under the Fritz 10 GUI with no issues so doubt its the interface.  You may need to run the Microsoft Visual C package. Download from here and install:

The other thought just to make certain its not the engine file in some way. Double click on the Rybka EXE file. You should get a black screen. Now type uci snd press enter. You should see a whole list of info and settings, starting with id name and id author, and running down ending in uci OK. If you don't, could be something wrong with the engine you bought.
Up Topic Rybka Support & Discussion / Rybka Support / Install help!

Powered by mwForum 2.27.4 © 1999-2012 Markus Wichitill