Not logged inRybka Chess Community Forum
Up Topic Rybka Support & Discussion / Rybka Support / consolidation of Large Pages threads
- - By Wayne Lowrance (***) Date 2010-06-04 15:27
Hello, I am stubborn. Desperate to make large pages work. The procedure is not complicated.
Making it work is for me, has been a nightmare. So I have started a new thread consolidated various responses.
First  I copy and paste my stuff.
I have tried, many different names, including, everyone, administrator, WAYNE-PC, Wayne Lowrance, etc.
I have tried all powers of 2 hash sized 64-2048 meg. I have tried all the reported verification post for how
to tell if it is working. It IS not.
I do not think it is a memory frag problem. The telling report from the engine
CreateFileMapping should tell me the problem.
I have wasted a lot of forum bandwidth on this issue, I am sorry. I will stop soon, one way or the other.

R4 engine reports the following:

Use large pages enabled.
Large pages not used-  CreateFilemapping returned invalid handle.
Please check memory fragmentation, privileges, UAC and (Reboot if
necessary.
Children restarted

I think that the engine is telling me that it has not found my computer
administrative name. In this vain I have worked that to death, but no luck yet.

"Here is my stuff:
Macpro early 2008. 8 gig ram. two Hard drives. HD#1, 2 TB partitioned with
Mac OS and Windows vista supreme 64. Hard drive #2 500 gig formatted
with Vista.
Both drives have  6 man TB's. #2 for TB backup.
I am using R4 loaded in the Vista partition of the 2 TB drive.
I have deactivated UAC.

BTW there has been  enable/disable HT threads here.. All say, Rybka runs best with it off.
Problem is It is not available to toggle off in a MacPro, always enabled. Just mentioning this as
maybe It affects Large Pages.
Let' see, what else, i guess that is about it.
Thanks all for working with me
Wayne
Parent - - By Wayne Lowrance (***) Date 2010-06-04 17:24
Praise the lord. It works :)

LP                   NLP             speedup
--                   ----             -------

399 Kn/s           334 Kn/s      16 %
Parent - By Vasik Rajlich (Silver) [pl] Date 2010-06-04 17:56
Congrats. :)

Vas
Parent - - By keoki010 (Silver) [us] Date 2010-06-04 18:04
Ok, now for the hard part! :lol:  What enabled it?  :twisted:
Parent - By Wayne Lowrance (***) Date 2010-06-04 19:44
I did the procedure by scratch. inserted "everyone"
when I started Rybka I watched for about 30 seconds, nothing happened, except i got feedback from
engine that I had enabled long pages. This has always been the case but never waited long enough to get
the engine replay  "using large page= 2,150,000.000, children restarted". This last time,I left computer room to go assist my wife
with bringing in the groceries. When I returned i saw that it was working :)
You know, the very first time I did this several days ago with "everyone" named. I was just impatient.
Should have waited for a minute or so cause it was probably working.
My grateful thanks to all who have been patient with me.
Wayne
Parent - - By Ray (****) Date 2010-06-04 20:06

> Praise the lord. It works :-)
>
> LP                   NLP             speedup
> --                   ----             -------
>
> 399 Kn/s           334 Kn/s      16 %


In the tests I've done on my machine, I "only" see about a 8-10% speedup. But it's free, so no complaints
Parent - By Wayne Lowrance (***) Date 2010-06-04 20:24
Interesting. The speedup does not seem to be cast in concrete with
8 cores at least, it does vary a little, not that much tho
Up Topic Rybka Support & Discussion / Rybka Support / consolidation of Large Pages threads

Powered by mwForum 2.27.4 © 1999-2012 Markus Wichitill